ICode9

精准搜索请尝试: 精确搜索
首页 > 其他分享> 文章详细

1046 Shortest Distance-PAT甲级

2019-08-31 13:39:31  阅读:252  来源: 互联网

标签:Distance PAT 1046 exits distance int dst between each


The task is really simple: given N exits on a highway which forms a simple cycle, you are supposed to tell the shortest distance between any pair of exits.

Input Specification:

Each input file contains one test case. For each case, the first line contains an integer N (in [3,10​5​​]), followed by N integer distances D​1​​ D​2​​ ⋯ D​N​​, where D​i​​ is the distance between the i-th and the (i+1)-st exits, and D​N​​ is between the N-th and the 1st exits. All the numbers in a line are separated by a space. The second line gives a positive integer M (≤10​4​​), with M lines follow, each contains a pair of exit numbers, provided that the exits are numbered from 1 to N. It is guaranteed that the total round trip distance is no more than 10​7​​.

Output Specification:

For each test case, print your results in M lines, each contains the shortest distance between the corresponding given pair of exits.

Sample Input:

5 1 2 4 14 9
3
1 3
2 5
4 1

Sample Output:

3
10
7

解题思路:dst[i]数组表示结点i+1到结点1的距离,dst[n]表示整个环的距离,求任意两点i与j的距离可以表示成

res=min(abs(dst[j-1]-dst[i-1]),abs(dst[n]-abs(dst[j-1]-dst[i-1)) 的形式

满分代码如下:

#include<bits/stdc++.h>
using namespace std;
const int N=100005;
int dst[N];
int main(){
	memset(dst,0,sizeof(dst));
	int n,m;
	scanf("%d",&n);
	for(int i=1;i<=n;i++){
		scanf("%d",&dst[i]);
		dst[i]+=dst[i-1];
	}
	scanf("%d",&m);
	int u,v,res;
	for(int i=1;i<=m;i++){
		scanf("%d%d",&u,&v);
		res=min(abs(dst[v-1]-dst[u-1]),abs(dst[n]-abs(dst[v-1]-dst[u-1])));
		printf("%d\n",res);
	}
	return 0;
}

 

标签:Distance,PAT,1046,exits,distance,int,dst,between,each
来源: https://blog.csdn.net/amf12345/article/details/100171865

本站声明: 1. iCode9 技术分享网(下文简称本站)提供的所有内容,仅供技术学习、探讨和分享;
2. 关于本站的所有留言、评论、转载及引用,纯属内容发起人的个人观点,与本站观点和立场无关;
3. 关于本站的所有言论和文字,纯属内容发起人的个人观点,与本站观点和立场无关;
4. 本站文章均是网友提供,不完全保证技术分享内容的完整性、准确性、时效性、风险性和版权归属;如您发现该文章侵犯了您的权益,可联系我们第一时间进行删除;
5. 本站为非盈利性的个人网站,所有内容不会用来进行牟利,也不会利用任何形式的广告来间接获益,纯粹是为了广大技术爱好者提供技术内容和技术思想的分享性交流网站。

专注分享技术,共同学习,共同进步。侵权联系[81616952@qq.com]

Copyright (C)ICode9.com, All Rights Reserved.

ICode9版权所有