ICode9

精准搜索请尝试: 精确搜索
首页 > 其他分享> 文章详细

The Missing Number

2019-08-30 22:38:44  阅读:248  来源: 互联网

标签:Missing int positive Specification Number Output integer line


                                       7-1 The Missing Number (20 分)

Given N integers, you are supposed to find the smallest positive integer that is NOT in the given list.

Input Specification:

Each input file contains one test case. For each case, the first line gives a positive integer N (≤10​5​​). Then N integers are given in the next line, separated by spaces. All the numbers are in the range of int.

Output Specification:

Print in a line the smallest positive integer that is missing from the input list.

Sample Input:

10
5 -25 9 6 1 3 4 2 5 17

Sample Output:

7

思路:将n个数插入到集合s中,然后i从1向后遍历,如果i不在集合s中输出i程序结束,否则i++

上AC代码:

#include <iostream>
#include<bits/stdc++.h>
using namespace std;

int main()
{
    set<int> s;
    int n,e;
    cin>>n;
    for(int i=0;i<n;i++)
    {
        cin>>e;
        s.insert(e);
    }
    int i=1;
    while(i)
    {
        if(s.find(i)==s.end())
        {
            cout<<i<<endl;
            return 0;
        }
        i++;
    }
    return 0;
}

 

标签:Missing,int,positive,Specification,Number,Output,integer,line
来源: https://blog.csdn.net/qq_42681421/article/details/100166764

本站声明: 1. iCode9 技术分享网(下文简称本站)提供的所有内容,仅供技术学习、探讨和分享;
2. 关于本站的所有留言、评论、转载及引用,纯属内容发起人的个人观点,与本站观点和立场无关;
3. 关于本站的所有言论和文字,纯属内容发起人的个人观点,与本站观点和立场无关;
4. 本站文章均是网友提供,不完全保证技术分享内容的完整性、准确性、时效性、风险性和版权归属;如您发现该文章侵犯了您的权益,可联系我们第一时间进行删除;
5. 本站为非盈利性的个人网站,所有内容不会用来进行牟利,也不会利用任何形式的广告来间接获益,纯粹是为了广大技术爱好者提供技术内容和技术思想的分享性交流网站。

专注分享技术,共同学习,共同进步。侵权联系[81616952@qq.com]

Copyright (C)ICode9.com, All Rights Reserved.

ICode9版权所有