ICode9

精准搜索请尝试: 精确搜索
首页 > 其他分享> 文章详细

Fliptile POJ - 3279

2019-08-10 15:40:54  阅读:247  来源: 互联网

标签:int Fliptile flip POJ they cows white include 3279


Farmer John knows that an intellectually satisfied cow is a happy cow who will give more milk. He has arranged a brainy activity for cows in which they manipulate an M × N grid (1 ≤ M ≤ 15; 1 ≤ N ≤ 15) of square tiles, each of which is colored black on one side and white on the other side.

As one would guess, when a single white tile is flipped, it changes to black; when a single black tile is flipped, it changes to white. The cows are rewarded when they flip the tiles so that each tile has the white side face up. However, the cows have rather large hooves and when they try to flip a certain tile, they also flip all the adjacent tiles (tiles that share a full edge with the flipped tile). Since the flips are tiring, the cows want to minimize the number of flips they have to make.

Help the cows determine the minimum number of flips required, and the locations to flip to achieve that minimum. If there are multiple ways to achieve the task with the minimum amount of flips, return the one with the least lexicographical ordering in the output when considered as a string. If the task is impossible, print one line with the word “IMPOSSIBLE”.

Input
Line 1: Two space-separated integers: M and N
Lines 2… M+1: Line i+1 describes the colors (left to right) of row i of the grid with N space-separated integers which are 1 for black and 0 for white
Output
Lines 1… M: Each line contains N space-separated integers, each specifying how many times to flip that particular location.
Sample Input
4 4
1 0 0 1
0 1 1 0
0 1 1 0
1 0 0 1
Sample Output
0 0 0 0
1 0 0 1
1 0 0 1
0 0 0 0

#include<iostream>
#include <algorithm>
#include <string.h>
#include <cstdio>
#include <queue>
#define read(x) scanf("%d",&x)
using namespace std;
int n,k,m=0;
const int N=1e1+7;

int a[N][N],t[N][N];
int dx[5]={0,0,1,-1,0};
int dy[5]={1,-1,0,0,0};
bool ok;
bool inedge(int x,int y)
{
    return x>=0&&x<n&&y>=0&&y<m;
}
void change(int x,int y)
{
    for(int j=0;j<5;j++){
        if(inedge(x+dx[j],y+dy[j]))
            a[x+dx[j]][y+dy[j]]^=1;
    }
}
void dfs(int x)
{
    if(ok) return;
    if(x==n){
        for(int i=0;i<n;i++)
            for(int j=0;j<m;j++)
                if(a[i][j]) return ;
        ok=true;
        for(int i=0;i<n;i++)
            for(int j=0;j<m;j++)
                printf("%d%c",t[i][j],j==m-1?'\n':' ');
        return;
    }
    int p[N],tot=0;
    for(int i=0;i<m;i++){
        if(a[x-1][i]){
            t[x][i]=1;
            change(x,i);
            p[tot++]=i;
        }
    }
    dfs(x+1);
    for(int i=0;i<tot;i++){
        change(x,p[i]);
    }
}
int main()
{
    while(~scanf("%d%d",&n,&m)){
        for(int i=0;i<n;i++)
            for(int j=0;j<m;j++)
                read(a[i][j]);
        ok=false;
        for(int i=0;i<(1<<m)&&!ok;i++){
            memset(t,0,sizeof(t));
            for(int j=0;j<m;j++){
                if(i&(1<<j)){
                    change(0,j);
                    t[0][j]=1;
                }
            }
            dfs(1);
            for(int j=0;j<m;j++){
                if(i&(1<<j)){
                    change(0,j);
                }
            }
        }
        if(!ok) puts("IMPOSSIBLE");
    }

    return 0;
}

标签:int,Fliptile,flip,POJ,they,cows,white,include,3279
来源: https://blog.csdn.net/Carish/article/details/99078808

本站声明: 1. iCode9 技术分享网(下文简称本站)提供的所有内容,仅供技术学习、探讨和分享;
2. 关于本站的所有留言、评论、转载及引用,纯属内容发起人的个人观点,与本站观点和立场无关;
3. 关于本站的所有言论和文字,纯属内容发起人的个人观点,与本站观点和立场无关;
4. 本站文章均是网友提供,不完全保证技术分享内容的完整性、准确性、时效性、风险性和版权归属;如您发现该文章侵犯了您的权益,可联系我们第一时间进行删除;
5. 本站为非盈利性的个人网站,所有内容不会用来进行牟利,也不会利用任何形式的广告来间接获益,纯粹是为了广大技术爱好者提供技术内容和技术思想的分享性交流网站。

专注分享技术,共同学习,共同进步。侵权联系[81616952@qq.com]

Copyright (C)ICode9.com, All Rights Reserved.

ICode9版权所有