ICode9

精准搜索请尝试: 精确搜索
首页 > 其他分享> 文章详细

Seek the Name, Seek the Fame POJ - 2752

2019-08-08 21:08:09  阅读:285  来源: 互联网

标签:suffix name int prefix POJ 2752 include Seek string


The little cat is so famous, that many couples tramp over hill and dale to Byteland, and asked the little cat to give names to their newly-born babies. They seek the name, and at the same time seek the fame. In order to escape from such boring job, the innovative little cat works out an easy but fantastic algorithm:

Step1. Connect the father’s name and the mother’s name, to a new string S.
Step2. Find a proper prefix-suffix string of S (which is not only the prefix, but also the suffix of S).

Example: Father=‘ala’, Mother=‘la’, we have S = ‘ala’+‘la’ = ‘alala’. Potential prefix-suffix strings of S are {‘a’, ‘ala’, ‘alala’}. Given the string S, could you help the little cat to write a program to calculate the length of possible prefix-suffix strings of S? (He might thank you by giving your baby a name:)
Input
The input contains a number of test cases. Each test case occupies a single line that contains the string S described above.

Restrictions: Only lowercase letters may appear in the input. 1 <= Length of S <= 400000.
Output
For each test case, output a single line with integer numbers in increasing order, denoting the possible length of the new baby’s name.
Sample Input
ababcababababcabab
aaaaa
Sample Output
2 4 9 18
1 2 3 4 5

题意

找到前缀后缀公共子串,就是next数组的基本性质;

思路

对next数组递归查询


 /*
/ \7    ∠_/
/ │   / /
│ Z _, < /        / `ヽ
│     ヽ         /   〉
Y     `  /      /  /
イ● 、 ●  ⊂⊃    〈 /
()  へ     |      \〈
 > ー 、_  ィ   │     //
	/ へ   / ノ<|    \\
	ヽ_ノ  (_/  │   //
	   7 | /      \    / /
		>―r ̄ ̄`ー―_ _/
*/
#include <iostream>
#include <cstdio>
#include <fstream>
#include <algorithm>
#include <cmath>
#include <deque>
#include <vector>
#include <queue>
#include <string>
#include <cstring>
#include <map>
#include <stack>
#include <set>

#define N 10000+5
#define inf 0x3f3f3f3f
using namespace std;
typedef long long ll;
int n, m;
int nex[400005];
char s1[400005], s2[400005];
int ans[400005];
int len2;
void  getNext()
{
	nex[0] = -1;
	int k = -1;
	int j = 0;
	while (j <n)
	{
		if (k == -1 || s2[j] == s2[k])
		{
			++k;
			++j;
			nex[j] = k;
		}
		else
		{
			k = nex[k];
		}
	}
}

int main()
{
	//int T = 1;

	while (scanf("%s", s2)!=EOF)
	{
		//memset(nex,-1, sizeof(nex));
		//scanf("%s", s2);
		n = strlen(s2);
		   getNext();
		int cnt = 0;
		//int ans[ = n;
		while (n > 0)
		{
			ans[cnt++] = n;
			n = nex[n];

		}
		for (int i = cnt - 1; i >= 0; i--)
		{
			printf("%d ", ans[i]);
		}
		printf("\n");

	}
	return 0;
}


标签:suffix,name,int,prefix,POJ,2752,include,Seek,string
来源: https://blog.csdn.net/qq_43619680/article/details/98885033

本站声明: 1. iCode9 技术分享网(下文简称本站)提供的所有内容,仅供技术学习、探讨和分享;
2. 关于本站的所有留言、评论、转载及引用,纯属内容发起人的个人观点,与本站观点和立场无关;
3. 关于本站的所有言论和文字,纯属内容发起人的个人观点,与本站观点和立场无关;
4. 本站文章均是网友提供,不完全保证技术分享内容的完整性、准确性、时效性、风险性和版权归属;如您发现该文章侵犯了您的权益,可联系我们第一时间进行删除;
5. 本站为非盈利性的个人网站,所有内容不会用来进行牟利,也不会利用任何形式的广告来间接获益,纯粹是为了广大技术爱好者提供技术内容和技术思想的分享性交流网站。

专注分享技术,共同学习,共同进步。侵权联系[81616952@qq.com]

Copyright (C)ICode9.com, All Rights Reserved.

ICode9版权所有