ICode9

精准搜索请尝试: 精确搜索
首页 > 其他分享> 文章详细

杭电6629string matching

2019-08-06 10:40:29  阅读:242  来源: 互联网

标签:ch string int ll len 杭电 str 6629string matching


题目描述

String matching is a common type of problem in computer science. One string matching problem is as following:

Given a string s[0…len−1], please calculate the length of the longest common prefix of s[i…len−1] and s[0…len−1] for each i>0.

I believe everyone can do it by brute force.
The pseudo code of the brute force approach is as the following:


We are wondering, for any given string, what is the number of compare operations invoked if we use the above algorithm. Please tell us the answer before we attempt to run this algorithm.
 

 

输入

The first line contains an integer T, denoting the number of test cases.
Each test case contains one string in a line consisting of printable ASCII characters except space.

* 1≤T≤30
* string length ≤106 for every string

 

输出

For each test, print an integer in one line indicating the number of compare operations invoked if we run the algorithm in the statement against the input string.

 

样例输入

复制样例数据

3
_Happy_New_Year_
ywwyww
zjczzzjczjczzzjc

样例输出

17
7
32

 

扩展kmp板题,只用到next数组就可以

#include<bits/stdc++.h>
using namespace std;
typedef long long ll;
typedef unsigned long long ull;
const ll mod=1e9+7;
const int modp=998244353;
const int maxn=1e6+50;
const double eps=1e-6;
#define lowbit(x)  x&(-x)
#define INF 0x3f3f3f3f
inline int read()
{
    int x=0,f=1;
    char ch=getchar();
    while(ch<'0'||ch>'9')
    {
        if(ch=='-')
            f=-1;
        ch=getchar();
    }
    while(ch>='0'&&ch<='9')
    {
        x=x*10+ch-'0';
        ch=getchar();
    }
    return x*f;
}
int dcmp(double x)
{
    if(fabs(x)<eps)return 0;
    return (x>0)?1:-1;
}
int gcd(int a,int b)
{
    return b?gcd(b,a%b):a;
}
ll qmod(ll a,ll b)
{
    ll ans=1;
    while(b)
    {
        if(b&1)
        {
            ans=(ans*a)%mod;
        }
        b>>=1;
        a=(a*a)%mod;
    }
    return ans;
}
char str[maxn];
int nex[maxn];
ll getNext(char str[])
{
    int i=0,j,po,len=strlen(str);
    ll ans=0;
    nex[0]=len; //初始化next[0]
    while(str[i]==str[i+1] && i+1<len) i++; nex[1]=i; //计算next[1]
    ans+=nex[1];
    if(nex[1]!=len-1)ans++;
    po=1; //初始化po的位置
    for(i=2;i<len;i++)
    {
        if(nex[i-po]+i < nex[po]+po) //第一种情况,可以直接得到next[i]的值
            nex[i]=nex[i-po];
        else //第二种情况,要继续匹配才能得到next[i]的值
        {
            j = nex[po]+po-i;
            if(j<0) j=0; //如果i>po+next[po],则要从头开始匹配
            while(i+j<len && str[j]==str[j+i]) j++; nex[i]=j;
            po=i; //更新po的位置
        }
        ans+=nex[i];
        if(nex[i]!=len-i)ans++;
    }
    return ans;
}
int main()
{
    int T;
    scanf("%d",&T);
    while(T--){
        scanf("%s",str);
        printf("%lld\n",getNext(str));
    }
    return 0;
}

 

标签:ch,string,int,ll,len,杭电,str,6629string,matching
来源: https://blog.csdn.net/weixin_41370251/article/details/98593531

本站声明: 1. iCode9 技术分享网(下文简称本站)提供的所有内容,仅供技术学习、探讨和分享;
2. 关于本站的所有留言、评论、转载及引用,纯属内容发起人的个人观点,与本站观点和立场无关;
3. 关于本站的所有言论和文字,纯属内容发起人的个人观点,与本站观点和立场无关;
4. 本站文章均是网友提供,不完全保证技术分享内容的完整性、准确性、时效性、风险性和版权归属;如您发现该文章侵犯了您的权益,可联系我们第一时间进行删除;
5. 本站为非盈利性的个人网站,所有内容不会用来进行牟利,也不会利用任何形式的广告来间接获益,纯粹是为了广大技术爱好者提供技术内容和技术思想的分享性交流网站。

专注分享技术,共同学习,共同进步。侵权联系[81616952@qq.com]

Copyright (C)ICode9.com, All Rights Reserved.

ICode9版权所有