ICode9

精准搜索请尝试: 精确搜索
首页 > 其他分享> 文章详细

1070 Mooncake (25 分) 贪心

2019-08-05 16:07:38  阅读:236  来源: 互联网

标签:sell 25 int 1070 tons num products Mooncake amout


Mooncake is a Chinese bakery product traditionally eaten during the Mid-Autumn Festival. Many types of fillings and crusts can be found in traditional mooncakes according to the region’s culture. Now given the inventory amounts and the prices of all kinds of the mooncakes, together with the maximum total demand of the market, you are supposed to tell the maximum profit that can be made.
Note: partial inventory storage can be taken. The sample shows the following situation: given three kinds of mooncakes with inventory amounts being 180, 150, and 100 thousand tons, and the prices being 7.5, 7.2, and 4.5 billion yuans. If the market demand can be at most 200 thousand tons, the best we can do is to sell 150 thousand tons of the second kind of mooncake, and 50 thousand tons of the third kind. Hence the total profit is 7.2 + 4.5/2 = 9.45 (billion yuans).

Input Specification:

Each input file contains one test case. For each case, the first line contains 2 positive integers N (≤1000), the number of different kinds of mooncakes, and D (≤500 thousand tons), the maximum total demand of the market. Then the second line gives the positive inventory amounts (in thousand tons), and the third line gives the positive prices (in billion yuans) of N kinds of mooncakes. All the numbers in a line are separated by a space.

Output Specification:

For each test case, print the maximum profit (in billion yuans) in one line, accurate up to 2 decimal places.

Sample Input:

3 200
180 150 100
7.5 7.2 4.5

Sample Output:

9.45

Note

  1. 题意:已知总每种的总销售额和数量,求需求之内最大利润
  2. 注意测试点2卡住,amouts以千位单位,要是double型

Code

#include<iostream>
#include<algorithm>
using namespace std;
const int MAX = 1E5;
struct product{
	double amout;
	double sum_price;
	double value;
}products[MAX];
bool cmp(product a, product b){
	return a.value < b.value;
}

int main(){ 
    int num, i;
    int max_need;
    cin >> num >> max_need;
    for(int i = 0; i < num; i++){
        cin  >> products[i].amout;
    }
    for(int i = 0; i < num; i++){
        cin >>products[i].sum_price;
        if(products[i].amout != 0) products[i].value =products[i].sum_price /products[i].amout;
        else products[i].value = 0;
    }
    sort(products, products + num, cmp);
    int sell_num = 0;
    double sell = 0;
    int j = num - 1;
    while(sell_num + products[j].amout <= max_need && j >= 0){
        sell +=products[j].sum_price;
        sell_num +=  products[j].amout ;
        j--;
    }
    if( j >= 0 && sell_num+ products[j].amout  > max_need){
        sell += (max_need - sell_num) * products[j].value;
    }
    printf("%.2lf", sell);
    return 0;

}

标签:sell,25,int,1070,tons,num,products,Mooncake,amout
来源: https://blog.csdn.net/qq_39339575/article/details/98492932

本站声明: 1. iCode9 技术分享网(下文简称本站)提供的所有内容,仅供技术学习、探讨和分享;
2. 关于本站的所有留言、评论、转载及引用,纯属内容发起人的个人观点,与本站观点和立场无关;
3. 关于本站的所有言论和文字,纯属内容发起人的个人观点,与本站观点和立场无关;
4. 本站文章均是网友提供,不完全保证技术分享内容的完整性、准确性、时效性、风险性和版权归属;如您发现该文章侵犯了您的权益,可联系我们第一时间进行删除;
5. 本站为非盈利性的个人网站,所有内容不会用来进行牟利,也不会利用任何形式的广告来间接获益,纯粹是为了广大技术爱好者提供技术内容和技术思想的分享性交流网站。

专注分享技术,共同学习,共同进步。侵权联系[81616952@qq.com]

Copyright (C)ICode9.com, All Rights Reserved.

ICode9版权所有