ICode9

精准搜索请尝试: 精确搜索
首页 > 其他分享> 文章详细

渣渣如我的ACM刨坑之路-001:Fliptile --POJ3279

2019-07-11 13:05:46  阅读:226  来源: 互联网

标签:POJ3279 20 int 刨坑 flip 001 they cows white


@TOC

POJ3279:Fliptile

Time Limit: 2000ms Memory Limit: 65536K
Total Submissions: 【好多好多吧】 Accepted: 【反正这之前没我】

Description

Farmer John knows that an intellectually satisfied cow is a happy cow who will give more milk. He has arranged a brainy activity for cows in which they manipulate an M × N grid (1 ≤ M ≤ 15; 1 ≤ N ≤ 15) of square tiles, each of which is colored black on one side and white on the other side.

As one would guess, when a single white tile is flipped, it changes to black; when a single black tile is flipped, it changes to white. The cows are rewarded when they flip the tiles so that each tile has the white side face up. However, the cows have rather large hooves and when they try to flip a certain tile, they also flip all the adjacent tiles (tiles that share a full edge with the flipped tile). Since the flips are tiring, the cows want to minimize the number of flips they have to make.

Help the cows determine the minimum number of flips required, and the locations to flip to achieve that minimum. If there are multiple ways to achieve the task with the minimum amount of flips, return the one with the least lexicographical ordering in the output when considered as a string. If the task is impossible, print one line with the word “IMPOSSIBLE”.

Input

Line 1: Two space-separated integers: M and N
Lines 2…M+1: Line i+1 describes the colors (left to right) of row i of the grid with N space-separated integers which are 1 for black and 0 for white

Output

Lines 1…M: Each line contains N space-separated integers, each specifying how many times to flip that particular location.

Sample Input

4 4
1 0 0 1
0 1 1 0
1 0 0 1
0 1 1 0

Sample Output

0 0 0 0
1 0 0 1
0 0 0 0
1 0 0 1

中文大意:

有一个n*m的格子,每个格子都有黑白两面(0表示白色,1表示黑色)。需要我们把所有的格子都反转成黑色,每反转一个格子,它上下左右的格子都会跟着反转。请求出用最小步数完成反转时每个格子反转的次数。有多个解时,输出字典序最小的一组。

这里是一种思路:
可以先指定最上面一行的翻转方法。此时能够反转(1,1)的只有(2,1),所以直接判断(2,1)是否需要翻转。直到确定第二行,依次判断到最后一行。最后判断最后一行是否全为白色来确定当前方案是否可行。 像这样的方法,我们枚举这一行所有的情况,共2n种可能。 时间复杂度为O(n * m * 2m)。

不管了,先贴代码:

#include <iostream>
#include <cstdio>
#include <cstring>
int n,m,map[20][20];
int opt[20][20];
int flip[20][20]; 
int dir[5][2]={{1,0},{-1,0},{0,0},{0,-1},{0,1}};
 
int judge(int x,int y)
{
	int i,c=map[x][y];
	for(i=0;i<5;++i)
	{
		int x2=x+dir[i][0],y2=y+dir[i][1];
		if(0<=x2&&x2<n&&0<=y2&&y2<m)
			c+=flip[x2][y2];
	}
	return c%2;
}
 
int calc()
{
	int i,j,res;
	for(i=1;i<n;++i)
	{
		for(j=0;j<m;++j)
		{
			if(judge(i-1,j)!=0)			//上方格子是黑色,必须必须反转(i,j)号格子 
				flip[i][j]=1; 
		}
	}
	for(i=0;i<m;++i)					//判断最后一行是否全白 
	{
		if(judge(n-1,i)!=0)			//当前方案不行 
			return -1;
	}
	res=0;
	for(i=0;i<n;++i)
	{
		for(j=0;j<m;++j)
		{
			res+=flip[i][j];				//统计当前方案的反转次数 
		}
	}
	return res;
}
 
int main()
{
	int i,j,ans,num;
	while(scanf("%d%d",&n,&m)!=EOF)
	{
		for(i=0;i<n;++i)
		{
			for(j=0;j<m;++j)
				scanf("%d",&map[i][j]);
		}
		ans=-1;
		//按照字典序尝试第一行所有的可能性,方案为2^m种 
		for(i=0;i< 1<<m;++i)
		{
			memset(flip,0,sizeof(flip));
			for(j=0;j<m;++j)
				flip[0][m-j-1]=i>>j&1;
			num=calc();
			if(num>=0&&(ans<0||ans>num))
			{
				ans=num;
				memcpy(opt,flip,sizeof(flip));			//把flip数组复制给opt数组 
			}
		}
		if(ans==-1)
			printf("IMPOSSIBLE\n");
		else
		{
			for(i=0;i<n;++i)
			{
				for(j=0;j<m;++j)
				{
					if(j==m-1)
						printf("%d\n",opt[i][j]);
					else
						printf("%d ",opt[i][j]);
				}
			}
		}
	}
	return 0;
}

还有。。。。。就没有了、懒!

标签:POJ3279,20,int,刨坑,flip,001,they,cows,white
来源: https://blog.csdn.net/Sakura_jc/article/details/89609588

本站声明: 1. iCode9 技术分享网(下文简称本站)提供的所有内容,仅供技术学习、探讨和分享;
2. 关于本站的所有留言、评论、转载及引用,纯属内容发起人的个人观点,与本站观点和立场无关;
3. 关于本站的所有言论和文字,纯属内容发起人的个人观点,与本站观点和立场无关;
4. 本站文章均是网友提供,不完全保证技术分享内容的完整性、准确性、时效性、风险性和版权归属;如您发现该文章侵犯了您的权益,可联系我们第一时间进行删除;
5. 本站为非盈利性的个人网站,所有内容不会用来进行牟利,也不会利用任何形式的广告来间接获益,纯粹是为了广大技术爱好者提供技术内容和技术思想的分享性交流网站。

专注分享技术,共同学习,共同进步。侵权联系[81616952@qq.com]

Copyright (C)ICode9.com, All Rights Reserved.

ICode9版权所有