ICode9

精准搜索请尝试: 精确搜索
首页 > 其他分享> 文章详细

Poj 1087 A Plug for UNIX 最大流

2019-06-03 13:00:30  阅读:194  来源: 互联网

标签:1087 Plug int s2 s1 devices UNIX 插座 chatou


Poj 1087 A Plug for UNIX 最大流

题目描述:

You are in charge of setting up the press room for the inaugural meeting of the United Nations Internet eXecutive (UNIX), which has an international mandate to make the free flow of information and ideas on the Internet as cumbersome and bureaucratic as possible.
Since the room was designed to accommodate reporters and journalists from around the world, it is equipped with electrical receptacles to suit the different shapes of plugs and voltages used by appliances in all of the countries that existed when the room was built. Unfortunately, the room was built many years ago when reporters used very few electric and electronic devices and is equipped with only one receptacle of each type. These days, like everyone else, reporters require many such devices to do their jobs: laptops, cell phones, tape recorders, pagers, coffee pots, microwave ovens, blow dryers, curling
irons, tooth brushes, etc. Naturally, many of these devices can operate on batteries, but since the meeting is likely to be long and tedious, you want to be able to plug in as many as you can.
Before the meeting begins, you gather up all the devices that the reporters would like to use, and attempt to set them up. You notice that some of the devices use plugs for which there is no receptacle. You wonder if these devices are from countries that didn't exist when the room was built. For some receptacles, there are several devices that use the corresponding plug. For other receptacles, there are no devices that use the corresponding plug.
In order to try to solve the problem you visit a nearby parts supply store. The store sells adapters that allow one type of plug to be used in a different type of outlet. Moreover, adapters are allowed to be plugged into other adapters. The store does not have adapters for all possible combinations of plugs and receptacles, but there is essentially an unlimited supply of the ones they do have.

Input
The input will consist of one case. The first line contains a single positive integer n (1 <= n <= 100) indicating the number of receptacles in the room. The next n lines list the receptacle types found in the room. Each receptacle type consists of a string of at most 24 alphanumeric characters. The next line contains a single positive integer m (1 <= m <= 100) indicating the number of devices you would like to plug in. Each of the next m lines lists the name of a device followed by the type of plug it uses (which is identical to the type of receptacle it requires). A device name is a string of at most 24 alphanumeric
characters. No two devices will have exactly the same name. The plug type is separated from the device name by a space. The next line contains a single positive integer k (1 <= k <= 100) indicating the number of different varieties of adapters that are available. Each of the next k lines describes a variety of adapter, giving the type of receptacle provided by the adapter, followed by a space, followed by the type of plug.
Output
A line containing a single non-negative integer indicating the smallest number of devices that cannot be plugged in.
Sample Input

4 
A 
B 
C 
D 
5 
laptop B 
phone C 
pager B 
clock B 
comb X 
3 
B X 
X A 
X D 

Sample Output

1

题意:题意:有插座和电器两种物品。首先有n种插座,n种插座用字符串表示,这n种插座可以理解为是插在电源上的插座。然后有m个电器,现在电器要充电,电器用字符串表示,每个电器都有自己可以插(且只可以插)的插座(这个插座可以不是那n个插在电源上的插座,可以是其他的插座)。现在有k个信息,s1 s2代表s1插座可以插到s2插座上去,这里类似于将插头转换了一下,这些s1与s2也可以不是那n个插在电源上的插座。给出这些个信息问你在尽可能满足多得电器工作的情况下还有多少个电器没有插座可以用。

思路:最大流,这样建图:建一个源点,指向所有电器,容量为1;所有电器指向他们可以插的那个插头上,容量为1;如果一个插头可以插到另一个插头,那么将s1指向s2,容量为无限大(因为这种转换器有无限多个);将所有插在电源上的插头指向汇点,容量为1。然后从源点到汇点求最大流即可。输出电器的数量-最大流。

题目中电器和插座都用字符串表示,所以使用stl的map比较方便。

代码如下:

#include <cstdio>
#include <cstring>
#include <string>
#include <map>
#include <algorithm>
#include <queue>
#include <iostream>
using namespace std;
const int maxn = 850;
const int INF = 0x3f3f3f3f;
int n, m, w, cnt;
map<string, int> chatou;
int mapp[maxn][maxn];
bool sign[maxn][maxn];
bool used[maxn];
queue<int> q;
bool bfs() {
    memset(used, 0, sizeof(used));
    memset(sign, 0, sizeof(sign));
    while (!q.empty())
        q.pop();
    used[0] = 1;
    q.push(0);
    while (!q.empty()) {
        for (int i = 0; i <= cnt; i++) {
            if (!used[i] && mapp[q.front()][i]) {
                q.push(i);
                used[i] = 1;
                sign[q.front()][i] = 1;
            }
        }
        q.pop();
    }
    if (used[cnt])
        return true;
    else
        return false;
}
int dfs(int v, int sum) {
    int s, t;
    if (v == cnt)
        return sum;
    s = sum;
    for (int i = 0; i <= cnt; i++) {
        if (sign[v][i]) {
            t = dfs(i, min(mapp[v][i], sum));
            mapp[v][i] -= t;
            mapp[i][v] += t;
            sum -= t;
        }
    }
    return s - sum;
}
int dinic() {
    int sum = 0;
    while (bfs()) {
        sum += dfs(0, INF);
    }
    return sum;
}
int main()
{
    memset(mapp, 0, sizeof(mapp));
    chatou.clear();
    scanf("%d", &n);
    string s1, s2;
    for (int i = 0; i < n; i++) {
        cin >> s1;
        chatou[s1] = i + 1;
    }
    int k = n;
    scanf("%d", &m);
    for (int i = 0; i < m; i++) {
        cin >> s1 >> s2;
        if (!chatou.count(s2))
            chatou[s2] = ++k;
        mapp[i + 1][m + chatou[s2]] = 1;
    }
    scanf("%d", &w);
    for (int i = 0; i < w; i++) {
        cin >> s1 >> s2;
        if (!chatou.count(s1))
            chatou[s1] = ++k;
        if (!chatou.count(s2))
            chatou[s2] = ++k;
        mapp[m + chatou[s1]][m + chatou[s2]] = INF;
    }
    for (int i = 0; i < m; i++)
        mapp[0][i + 1] = 1;
    for (int i = 0; i < n; i++)
        mapp[i + m + 1][m + k + 1] = 1;
    cnt = m + k + 1;
    printf("%d\n", m - dinic());
    return 0;
}

标签:1087,Plug,int,s2,s1,devices,UNIX,插座,chatou
来源: https://www.cnblogs.com/pot-a-to/p/10966913.html

本站声明: 1. iCode9 技术分享网(下文简称本站)提供的所有内容,仅供技术学习、探讨和分享;
2. 关于本站的所有留言、评论、转载及引用,纯属内容发起人的个人观点,与本站观点和立场无关;
3. 关于本站的所有言论和文字,纯属内容发起人的个人观点,与本站观点和立场无关;
4. 本站文章均是网友提供,不完全保证技术分享内容的完整性、准确性、时效性、风险性和版权归属;如您发现该文章侵犯了您的权益,可联系我们第一时间进行删除;
5. 本站为非盈利性的个人网站,所有内容不会用来进行牟利,也不会利用任何形式的广告来间接获益,纯粹是为了广大技术爱好者提供技术内容和技术思想的分享性交流网站。

专注分享技术,共同学习,共同进步。侵权联系[81616952@qq.com]

Copyright (C)ICode9.com, All Rights Reserved.

ICode9版权所有