ICode9

精准搜索请尝试: 精确搜索
首页 > 其他分享> 文章详细

Friends ZOJ - 3710(交集)

2019-05-02 16:54:39  阅读:282  来源: 互联网

标签:3710 int friendship ZOJ rd include Friends scanf define


Alice lives in the country where people like to make friends. The friendship is bidirectional and if any two person have no less than k friends in common, they will become friends in several days. Currently, there are totally n people in the country, and m friendship among them. Assume that any new friendship is made only when they have sufficient friends in common mentioned above, you are to tell how many new friendship are made after a sufficiently long time.

 

Input

There are multiple test cases.

The first lien of the input contains an integer T (about 100) indicating the number of test cases. Then T cases follow. For each case, the first line contains three integers n, m, k (1 ≤ n ≤ 100, 0 ≤ m ≤ n×(n-1)/2, 0 ≤ k ≤ n, there will be no duplicated friendship) followed by m lines showing the current friendship. The ith friendship contains two integers ui, vi (0 ≤ ui, vi < nui ≠ vi) indicating there is friendship between person ui and vi.

Note: The edges in test data are generated randomly.

Output

For each case, print one line containing the answer.

Sample Input

 

3
4 4 2
0 1
0 2
1 3
2 3
5 5 2
0 1
1 2
2 3
3 4
4 0
5 6 2
0 1
1 2
2 3
3 4
4 0
2 0

 

Sample Output

 

2
0
4

用set存边
然后如果两个点的交集大于等于k
则说明这两个可以连边
再用set存一下
重新开始判断(为什么 自己想想)
#include <iostream>
#include <cstdio>
#include <sstream>
#include <cstring>
#include <map>
#include <cctype>
#include <set>
#include <vector>
#include <stack>
#include <queue>
#include <algorithm>
#include <list>
#include <cmath>
#include <bitset>
#define rap(i, a, n) for(int i=a; i<=n; i++)
#define rep(i, a, n) for(int i=a; i<n; i++)
#define lap(i, a, n) for(int i=n; i>=a; i--)
#define lep(i, a, n) for(int i=n; i>a; i--)
#define rd(a) scanf("%d", &a)
#define rlld(a) scanf("%lld", &a)
#define rc(a) scanf("%c", &a)
#define rs(a) scanf("%s", a)
#define rb(a) scanf("%lf", &a)
#define rf(a) scanf("%f", &a)
#define pd(a) printf("%d\n", a)
#define plld(a) printf("%lld\n", a)
#define pc(a) printf("%c\n", a)
#define ps(a) printf("%s\n", a)
#define MOD 2018
#define LL long long
#define ULL unsigned long long
#define Pair pair<int, int>
#define mem(a, b) memset(a, b, sizeof(a))
#define _  ios_base::sync_with_stdio(0),cin.tie(0)
//freopen("1.txt", "r", stdin);
using namespace std;
const int maxn = 110000, INF = 0x7fffffff;

int n, m, k;
set<int> s[105];
set<int> ss;
int vis[105][105];
int main()
{
    int T;
    rd(T);
    while(T--)
    {
        int u, v;
        rd(n), rd(m), rd(k);
        for(int i = 0; i <= n; i++)
        {
            s[i].clear();
            for(int j = 0; j <= n; j++) vis[i][j] = 0;
        }
        for(int i = 0; i < m; i++)
        {
            rd(u), rd(v);
            s[u].insert(v), s[v].insert(u);
            vis[u][v] = vis[v][u] = 1;
        }
        int cnt = 0;
        for(int i = 0; i < n; i++)
        {
            for(int j = 0; j < n; j++)
            {
                if(i == j) continue;
                if(vis[i][j]) continue;
                if(s[i].size() < k || s[j].size() < k) continue;
                ss.clear();
                set_intersection(s[i].begin(), s[i].end(), s[j].begin(), s[j].end(), inserter(ss, ss.begin()));
                if(ss.size() >= k)
                {
                    cnt++;
                    vis[i][j] = vis[j][i] = 1;
                    s[i].insert(j);
                    s[j].insert(i);
                    i = j = 0;
                }
            }
        }
        pd(cnt);

    }


    return 0;
}

 

标签:3710,int,friendship,ZOJ,rd,include,Friends,scanf,define
来源: https://www.cnblogs.com/WTSRUVF/p/10802643.html

本站声明: 1. iCode9 技术分享网(下文简称本站)提供的所有内容,仅供技术学习、探讨和分享;
2. 关于本站的所有留言、评论、转载及引用,纯属内容发起人的个人观点,与本站观点和立场无关;
3. 关于本站的所有言论和文字,纯属内容发起人的个人观点,与本站观点和立场无关;
4. 本站文章均是网友提供,不完全保证技术分享内容的完整性、准确性、时效性、风险性和版权归属;如您发现该文章侵犯了您的权益,可联系我们第一时间进行删除;
5. 本站为非盈利性的个人网站,所有内容不会用来进行牟利,也不会利用任何形式的广告来间接获益,纯粹是为了广大技术爱好者提供技术内容和技术思想的分享性交流网站。

专注分享技术,共同学习,共同进步。侵权联系[81616952@qq.com]

Copyright (C)ICode9.com, All Rights Reserved.

ICode9版权所有