ICode9

精准搜索请尝试: 精确搜索
首页 > 其他分享> 文章详细

HUD Billboard (线段树)

2019-04-16 20:55:53  阅读:451  来源: 互联网

标签:HUD node val announcement int 线段 tree Billboard root


2795 Billboard

Problem Description

At the entrance to the university, there is a huge rectangular billboard of size h*w (h is its height and w is its width). The board is the place where all possible announcements are posted: nearest programming competitions, changes in the dining room menu, and other important information.

On September 1, the billboard was empty. One by one, the announcements started being put on the billboard.

Each announcement is a stripe of paper of unit height. More specifically, the i-th announcement is a rectangle of size 1 * wi.

When someone puts a new announcement on the billboard, she would always choose the topmost possible position for the announcement. Among all possible topmost positions she would always choose the leftmost one.

If there is no valid location for a new announcement, it is not put on the billboard (that's why some programming contests have no participants from this university).

Given the sizes of the billboard and the announcements, your task is to find the numbers of rows in which the announcements are placed.

 

Input

There are multiple cases (no more than 40 cases).

The first line of the input file contains three integer numbers, h, w, and n (1 <= h,w <= 10^9; 1 <= n <= 200,000) - the dimensions of the billboard and the number of announcements.

Each of the next n lines contains an integer number wi (1 <= wi <= 10^9) - the width of i-th announcement.

 

Output

For each announcement (in the order they are given in the input file) output one number - the number of the row in which this announcement is placed. Rows are numbered from 1 to h, starting with the top row. If an announcement can't be put on the billboard, output "-1" for this announcement.

 

Sample Input

3 5 5 2 4 3 3 3

 

Sample Output

1 2 1 3 -1

 

分析:

将广告牌的每一行空余位置做成线段树,可以方便查询从哪里开始放置,大幅度简化复杂度,类似于二分法查询。

代码:

#include<bits/stdc++.h>
using namespace std;
int h,w,n,val;

struct Node
{
    int l;
    int r;
    int val;
}node[800010];

void build_tree(int root,int l,int r)
{
    node[root].l=l,node[root].r=r,node[root].val=w;
    if(l==r)return;

    int mid=(l+r)/2;
    build_tree(root*2,l,mid);
    build_tree(root*2+1,mid+1,r);
}

void search_tree(int root,int l,int r)
{
    if(l==r){
        printf("%d\n",l);
        node[root].val-=val;
        return;
    }
    int mid=(l+r)/2;
    if(node[root*2].val>=val)search_tree(root*2,l,mid);
    else search_tree(root*2+1,mid+1,r);
    node[root].val=max(node[2*root].val,node[2*root+1].val);
}

int main()
{
	while(~scanf("%d%d%d",&h,&w,&n))
    {
        if(h>n)h=n;
        build_tree(1,1,h);
        while(n--){
            scanf("%d",&val);
            if(val>node[1].val)printf("-1\n");
            else search_tree(1,1,h);
        }
    }
	return 0;
}

 

标签:HUD,node,val,announcement,int,线段,tree,Billboard,root
来源: https://blog.csdn.net/qq_43700916/article/details/89341246

本站声明: 1. iCode9 技术分享网(下文简称本站)提供的所有内容,仅供技术学习、探讨和分享;
2. 关于本站的所有留言、评论、转载及引用,纯属内容发起人的个人观点,与本站观点和立场无关;
3. 关于本站的所有言论和文字,纯属内容发起人的个人观点,与本站观点和立场无关;
4. 本站文章均是网友提供,不完全保证技术分享内容的完整性、准确性、时效性、风险性和版权归属;如您发现该文章侵犯了您的权益,可联系我们第一时间进行删除;
5. 本站为非盈利性的个人网站,所有内容不会用来进行牟利,也不会利用任何形式的广告来间接获益,纯粹是为了广大技术爱好者提供技术内容和技术思想的分享性交流网站。

专注分享技术,共同学习,共同进步。侵权联系[81616952@qq.com]

Copyright (C)ICode9.com, All Rights Reserved.

ICode9版权所有