ICode9

精准搜索请尝试: 精确搜索
首页 > 其他分享> 文章详细

Modular Inverse(逆元)

2019-03-31 15:53:15  阅读:279  来源: 互联网

标签:Inverse return ll Modular 逆元 ex test integer include


题目连接:https://cn.vjudge.net/problem/ZOJ-3609

The modular modular multiplicative inverse of an integer a modulo m is an integer x such that a-1≡x (mod m). This is equivalent to ax≡1 (mod m).

Input

There are multiple test cases. The first line of input is an integer T ≈ 2000 indicating the number of test cases.

Each test case contains two integers 0 < a ≤ 1000 and 0 < m ≤ 1000.

Output

For each test case, output the smallest positive x. If such x doesn't exist, output "Not Exist".

Sample Input

3
3 11
4 12
5 13

Sample Output

4
Not Exist
8

 

#include <iostream>
#include <cstdio>
#include <cstring>
#include <algorithm>
#include <cmath>
using namespace std;
typedef long long ll;
const int maxn=1e5+5;
ll ex_gcd(ll a,ll b,ll &x,ll &y)
{
    if(a==0&&b==0)return -1;
    if(b==0)
    {
        x=1;
        y=0;
        return a;
    }
    ll d=ex_gcd(b,a%b,y,x);
    y-=a/b*x;
    return d;
}
ll ex_gcd1(ll a,ll n)
{
    ll x,y;
    ll d=ex_gcd(a,n,x,y);
    if(d==1)
    {
        if(x<0)
            return (x%n+n)%n;
        else if(x==0)
            return n;
        return x;
    }
    else return -1;
}
ll gcd(ll a,ll b)
{
    if(b==0)return a;
    return gcd(b,a%b);
}
int main()
{
    int T;
    scanf("%d",&T);
    while(T--)
    {
        ll a,b;
        scanf("%lld%lld",&a,&b);
        if(gcd(a,b)!=1)
        {
            printf("Not Exist\n");
            continue;
        }
        ll g=ex_gcd1(a,b);
        if(g==-1)
            printf("Not Exist\n");
        else
        {
            printf("%lld\n",g);
        }
    }
    return 0;
}

 

标签:Inverse,return,ll,Modular,逆元,ex,test,integer,include
来源: https://blog.csdn.net/qq_42936517/article/details/88929745

本站声明: 1. iCode9 技术分享网(下文简称本站)提供的所有内容,仅供技术学习、探讨和分享;
2. 关于本站的所有留言、评论、转载及引用,纯属内容发起人的个人观点,与本站观点和立场无关;
3. 关于本站的所有言论和文字,纯属内容发起人的个人观点,与本站观点和立场无关;
4. 本站文章均是网友提供,不完全保证技术分享内容的完整性、准确性、时效性、风险性和版权归属;如您发现该文章侵犯了您的权益,可联系我们第一时间进行删除;
5. 本站为非盈利性的个人网站,所有内容不会用来进行牟利,也不会利用任何形式的广告来间接获益,纯粹是为了广大技术爱好者提供技术内容和技术思想的分享性交流网站。

专注分享技术,共同学习,共同进步。侵权联系[81616952@qq.com]

Copyright (C)ICode9.com, All Rights Reserved.

ICode9版权所有