ICode9

精准搜索请尝试: 精确搜索
首页 > 其他分享> 文章详细

并查集

2019-03-31 09:42:46  阅读:326  来源: 互联网

标签:Ignatius knows int 查集 per know friends


一、思想

通俗的说就是将所有关系的都连接起来,比方说A和B是朋友,B和C是朋友,那么A和C也是朋友,就算是中间隔着100个朋友这样的也算是朋友。

具体实现:

通过两个函数实现。

一是查找父节点函数,此函数可以使用递归调用来压缩路径。

二是合并函数,将两个没有连接的点连接起来。

二、例题 HDU-1213 How Many Tables?

题目地址:http://acm.hdu.edu.cn/showproblem.php?pid=1213

Problem Description

Today is Ignatius' birthday. He invites a lot of
friends. Now it's dinner time. Ignatius wants to know how many tables he needs
at least. You have to notice that not all the friends know each other, and all
the friends do not want to stay with strangers.
One important rule for
this problem is that if I tell you A knows B, and B knows C, that means A, B, C
know each other, so they can stay in one table.
For example: If I tell
you A knows B, B knows C, and D knows E, so A, B, C can stay in one table, and
D, E have to stay in the other one. So Ignatius needs 2 tables at
least.

Input

The input starts with an integer T(1<=T<=25)
which indicate the number of test cases. Then T test cases follow. Each test
case starts with two integers N and M(1<=N,M<=1000). N indicates the
number of friends, the friends are marked from 1 to N. Then M lines follow. Each
line consists of two integers A and B(A!=B), that means friend A and friend B
know each other. There will be a blank line between two cases.

Output

For each test case, just output how many tables
Ignatius needs at least. Do NOT print any blanks.

Sample Input

    2
    5 3
    1 2
    2 3
    4 5
    5 1
    2 5

Sample Output

    2
    4

题目大意是求出有几个独立的集合。

AC代码:

#include<iostream>
#include<cstdio>
#include<string.h>

using namespace std;
int per[1000+10];
int root[1000+10];

int xfind( int a)
{
    if( a == per[a])
       return a;
    per[a] = xfind(per[a]);
    return per[a];
}

void mix( int a, int b)
{
    int f = xfind(a), l = xfind(b);
    if( f != l)
        per[l] = f;
}

int main()
{
    int t;
    int n, k;
    int a, b;

    cin >> t;
    while(t--)
    {
        int ans = 0;
        cin >> n >> k;
        for( int i = 1; i <= n; i++)
            per[i] = i;
        for( int i = 0; i < k; i++)
        {
            cin >> a >> b;
            mix( a, b);
        }
        memset( root, false, sizeof(root));
        for( int i = 1; i <= n; i++)
            root[xfind(i)] = 1;
        for( int i = 1; i <= n; i++)
            if(root[i])
                ans++;
        cout << ans << endl;
        getchar();
    }
    return 0;
}

带权并查集

此处留坑待填。

标签:Ignatius,knows,int,查集,per,know,friends
来源: https://www.cnblogs.com/trirabbits/p/10630253.html

本站声明: 1. iCode9 技术分享网(下文简称本站)提供的所有内容,仅供技术学习、探讨和分享;
2. 关于本站的所有留言、评论、转载及引用,纯属内容发起人的个人观点,与本站观点和立场无关;
3. 关于本站的所有言论和文字,纯属内容发起人的个人观点,与本站观点和立场无关;
4. 本站文章均是网友提供,不完全保证技术分享内容的完整性、准确性、时效性、风险性和版权归属;如您发现该文章侵犯了您的权益,可联系我们第一时间进行删除;
5. 本站为非盈利性的个人网站,所有内容不会用来进行牟利,也不会利用任何形式的广告来间接获益,纯粹是为了广大技术爱好者提供技术内容和技术思想的分享性交流网站。

专注分享技术,共同学习,共同进步。侵权联系[81616952@qq.com]

Copyright (C)ICode9.com, All Rights Reserved.

ICode9版权所有