ICode9

精准搜索请尝试: 精确搜索
首页 > 其他分享> 文章详细

POJ 经典DFS 2531

2019-03-22 22:52:04  阅读:201  来源: 互联网

标签:network int DFS subnetworks traffic between POJ nodes 2531


Network Saboteur

Time Limit: 2000MS   Memory Limit: 65536K
Total Submissions: 14742   Accepted: 7265

Description

A university network is composed of N computers. System administrators gathered information on the traffic between nodes, and carefully divided the network into two subnetworks in order to minimize traffic between parts.
A disgruntled computer science student Vasya, after being expelled from the university, decided to have his revenge. He hacked into the university network and decided to reassign computers to maximize the traffic between two subnetworks.
Unfortunately, he found that calculating such worst subdivision is one of those problems he, being a student, failed to solve. So he asks you, a more successful CS student, to help him.
The traffic data are given in the form of matrix C, where Cij is the amount of data sent between ith and jth nodes (Cij = Cji, Cii = 0). The goal is to divide the network nodes into the two disjointed subsets A and B so as to maximize the sum ∑Cij (i∈A,j∈B).

Input

The first line of input contains a number of nodes N (2 <= N <= 20). The following N lines, containing N space-separated integers each, represent the traffic matrix C (0 <= Cij <= 10000).
Output file must contain a single integer -- the maximum traffic between the subnetworks.

Output

Output must contain a single integer -- the maximum traffic between the subnetworks.

Sample Input

3
0 50 30
50 0 40
30 40 0

Sample Output

90

题意:把一些点分为两组,求这些点间的距离最大值

刚开始还以为是图论,遂wa

用DFS暴力搜索

将点一个个尝试着放到另一组中,递归,求最大值

#include<iostream>
#include<cstdio>
#include<cstring>
using namespace std;
#define range 25
int map[range][range];
bool vis[range];
int n,cnt;
void dfs(int d,int sum)
{
	int i,j;
	vis[d]=true;
	for(i=0;i<n;i++)
	{
		if(vis[i])
		sum-=map[d][i];
		else
		sum+=map[d][i];
		
	}
	
	cnt=cnt>sum?cnt:sum;
	for(i=d+1;i<n;i++)
	{
		dfs(i,sum);
		vis[i]=false;
		
	}
}
int main()
{
	while(cin>>n)
	{
		for(int i=0;i<n;i++)
		{
			for(int j=0;j<n;j++)
			{
				cin>>map[i][j];
			}
		}
		memset(vis,false,sizeof(vis));
		cnt=0;
		dfs(0,0);
		cout<<cnt<<endl;	
	}
	return 0;
}

 

标签:network,int,DFS,subnetworks,traffic,between,POJ,nodes,2531
来源: https://blog.csdn.net/qq_41325698/article/details/88751833

本站声明: 1. iCode9 技术分享网(下文简称本站)提供的所有内容,仅供技术学习、探讨和分享;
2. 关于本站的所有留言、评论、转载及引用,纯属内容发起人的个人观点,与本站观点和立场无关;
3. 关于本站的所有言论和文字,纯属内容发起人的个人观点,与本站观点和立场无关;
4. 本站文章均是网友提供,不完全保证技术分享内容的完整性、准确性、时效性、风险性和版权归属;如您发现该文章侵犯了您的权益,可联系我们第一时间进行删除;
5. 本站为非盈利性的个人网站,所有内容不会用来进行牟利,也不会利用任何形式的广告来间接获益,纯粹是为了广大技术爱好者提供技术内容和技术思想的分享性交流网站。

专注分享技术,共同学习,共同进步。侵权联系[81616952@qq.com]

Copyright (C)ICode9.com, All Rights Reserved.

ICode9版权所有