ICode9

精准搜索请尝试: 精确搜索
首页 > 其他分享> 文章详细

World Cup

2022-09-11 18:34:46  阅读:287  来源: 互联网

标签:Cup Sample held Output 12022 year World Input


Problem Statement

A sport event is held in June of every year whose remainder when divided by $4$ is $2$.
Suppose that it is now January of the year $Y$. In what year will this sport event be held next time?

Constraints

  • $2000 \leq Y \leq 3000$
  • $Y$ is an integer.

Input

Input is given from Standard Input in the following format:

$Y$

Output

Print the answer.


Sample Input 1

2022

Sample Output 1

2022

The remainder when $2022$ is divided by $4$ is $2$, so if it is now January of $2022$, the next games will be held in June of the same year.


Sample Input 2

2023

Sample Output 2

2026

Sample Input 3

3000

Sample Output 3

3002

模拟即可。

#include<cstdio>
int y;
int main()
{
	scanf("%d",&y);
	if(y%4==3)
		printf("%d",y+3);
	else
		printf("%d",y+(2-y%4));
}

标签:Cup,Sample,held,Output,12022,year,World,Input
来源: https://www.cnblogs.com/mekoszc/p/16684497.html

本站声明: 1. iCode9 技术分享网(下文简称本站)提供的所有内容,仅供技术学习、探讨和分享;
2. 关于本站的所有留言、评论、转载及引用,纯属内容发起人的个人观点,与本站观点和立场无关;
3. 关于本站的所有言论和文字,纯属内容发起人的个人观点,与本站观点和立场无关;
4. 本站文章均是网友提供,不完全保证技术分享内容的完整性、准确性、时效性、风险性和版权归属;如您发现该文章侵犯了您的权益,可联系我们第一时间进行删除;
5. 本站为非盈利性的个人网站,所有内容不会用来进行牟利,也不会利用任何形式的广告来间接获益,纯粹是为了广大技术爱好者提供技术内容和技术思想的分享性交流网站。

专注分享技术,共同学习,共同进步。侵权联系[81616952@qq.com]

Copyright (C)ICode9.com, All Rights Reserved.

ICode9版权所有