ICode9

精准搜索请尝试: 精确搜索
首页 > 其他分享> 文章详细

PAT Advanced 1024 Palindromic Number(25)

2022-08-22 22:05:12  阅读:199  来源: 互联网

标签:1024 PAT temp palindromic res number steps 25 numbers


题目描述:

A number that will be the same when it is written forwards or backwards is known as a Palindromic Number. For example, 1234321 is a palindromic number. All single digit numbers are palindromic numbers.

Non-palindromic numbers can be paired with palindromic ones via a series of operations. First, the non-palindromic number is reversed and the result is added to the original number. If the result is not a palindromic number, this is repeated until it gives a palindromic number. For example, if we start from 67, we can obtain a palindromic number in 2 steps: 67 + 76 = 143, and 143 + 341 = 484.

Given any positive integer N, you are supposed to find its paired palindromic number and the number of steps taken to find it.

Input Specification:

Each input file contains one test case. Each case consists of two positive numbers N and K, where N (≤1010) is the initial numer and K (≤100) is the maximum number of steps. The numbers are separated by a space.

Output Specification:

For each test case, output two numbers, one in each line. The first number is the paired palindromic number of N, and the second number is the number of steps taken to find the palindromic number. If the palindromic number is not found after K steps, just output the number obtained at the Kth step and K instead.

Sample Input 1:

67 3

Sample Output 1:

484
2

Sample Input 2:

69 3

Sample Output 2:

1353
3

算法描述:回文数

题目大意:

给定一个数字,和允许翻转后相加的次数k,求要多少次才能变成一个回文数字,输出那个回文数字和翻转相加了多少次,如果本身就是回文数字就输出0次,如果超过给定的次数k了,就输出那个不是回文的结果,并且输出给定的次数k

#include<iostream>
#include<algorithm>
using namespace std;

string s;
// 添加反转数
void add(string temp)
{
    string res;
    int len = s.size(), t = 0;
    for(int i = len - 1 ; i >= 0 ; i --)
    {
        t += (s[i] - '0') + (temp[i] - '0');
        res += (t % 10) + '0';
        t /= 10;
    }
    if(t)   res += '1';
    
    reverse(res.begin(), res.end());
    s = res;
}

int main()
{
    int k, step = 0;
    cin >> s >> k;
    for(step ; step < k ; step ++)
    {
        string temp = s;
        reverse(temp.begin(), temp.end());
        if(s == temp)  break;
        add(temp);
    }
    cout << s << endl << step;
    return 0;
}

标签:1024,PAT,temp,palindromic,res,number,steps,25,numbers
来源: https://www.cnblogs.com/yztozju/p/16614380.html

本站声明: 1. iCode9 技术分享网(下文简称本站)提供的所有内容,仅供技术学习、探讨和分享;
2. 关于本站的所有留言、评论、转载及引用,纯属内容发起人的个人观点,与本站观点和立场无关;
3. 关于本站的所有言论和文字,纯属内容发起人的个人观点,与本站观点和立场无关;
4. 本站文章均是网友提供,不完全保证技术分享内容的完整性、准确性、时效性、风险性和版权归属;如您发现该文章侵犯了您的权益,可联系我们第一时间进行删除;
5. 本站为非盈利性的个人网站,所有内容不会用来进行牟利,也不会利用任何形式的广告来间接获益,纯粹是为了广大技术爱好者提供技术内容和技术思想的分享性交流网站。

专注分享技术,共同学习,共同进步。侵权联系[81616952@qq.com]

Copyright (C)ICode9.com, All Rights Reserved.

ICode9版权所有