ICode9

精准搜索请尝试: 精确搜索
首页 > 其他分享> 文章详细

PAT Advanced 1036 Boys vs Girls(25)

2022-08-21 01:33:42  阅读:155  来源: 互联网

标签:25 PAT name Absent grade gender Girls line id


题目描述:

This time you are asked to tell the difference between the lowest grade of all the male students and the highest grade of all the female students.

Input Specification:

Each input file contains one test case. Each case contains a positive integer N, followed by N lines of student information. Each line contains a student's name, gender, ID and grade, separated by a space, where name and ID are strings of no more than 10 characters with no space, gender is either F (female) or M (male), and grade is an integer between 0 and 100. It is guaranteed that all the grades are distinct.

Output Specification:

For each test case, output in 3 lines. The first line gives the name and ID of the female student with the highest grade, and the second line gives that of the male student with the lowest grade. The third line gives the difference gradeF​−gradeM​. If one such kind of student is missing, output Absent in the corresponding line, and output NA in the third line instead.

Sample Input 1:

3
Joe M Math990112 89
Mike M CS991301 100
Mary F EE990830 95

Sample Output 1:

Mary EE990830
Joe Math990112
6

Sample Input 2:

1
Jean M AA980920 60

Sample Output 2:

Absent
Jean AA980920
NA

算法描述:模拟

题目大意:

给出整数n 以及 n个同学的信息(姓名 性别 学号 成绩)
第一行输出最低分男生的姓名和学号,第二行输出最高分女生的姓名和学号,第三个输出二者分差(男min - 女max)
如果没有某一性别的同学,则在相应行输出“Absent”,并在第三行输出“NA”

#include<bits/stdc++.h>
using namespace std;
string m_name = "Absent" , m_id , f_name ="Absent" , f_id ;
int m_grade = 101 , f_grade = -1;
int main()
{
    int n;
    cin >> n ;
    for(int i = 0 ; i < n ; i++ )
    {
        string name,id;
        char gender;
		int grade;
        cin >> name >> gender >> id >> grade ;
        if(gender == 'M' && (grade < m_grade || !i) )//性别 男 且 有更小成绩时
        {
            m_name = name ;
            m_id = id ;
            m_grade = grade ;
        }
        if(gender == 'F' && (grade > f_grade || !i) )//性别 女 且 有更大成绩时
        {
            f_name = name ;
            f_id = id ;
            f_grade = grade ;
        }
    }
    if(f_name == "Absent")  cout << f_name << endl ;
    else                    cout << f_name << " " << f_id << endl ;
    
    if(m_name == "Absent")  cout << m_name << endl ;
    else                    cout << m_name << " " << m_id << endl ;
    
    if(f_name != "Absent" && m_name != "Absent")    cout << f_grade - m_grade ;
    else                                            cout << "NA" ;
    return 0;
}

标签:25,PAT,name,Absent,grade,gender,Girls,line,id
来源: https://www.cnblogs.com/yztozju/p/16609186.html

本站声明: 1. iCode9 技术分享网(下文简称本站)提供的所有内容,仅供技术学习、探讨和分享;
2. 关于本站的所有留言、评论、转载及引用,纯属内容发起人的个人观点,与本站观点和立场无关;
3. 关于本站的所有言论和文字,纯属内容发起人的个人观点,与本站观点和立场无关;
4. 本站文章均是网友提供,不完全保证技术分享内容的完整性、准确性、时效性、风险性和版权归属;如您发现该文章侵犯了您的权益,可联系我们第一时间进行删除;
5. 本站为非盈利性的个人网站,所有内容不会用来进行牟利,也不会利用任何形式的广告来间接获益,纯粹是为了广大技术爱好者提供技术内容和技术思想的分享性交流网站。

专注分享技术,共同学习,共同进步。侵权联系[81616952@qq.com]

Copyright (C)ICode9.com, All Rights Reserved.

ICode9版权所有