ICode9

精准搜索请尝试: 精确搜索
首页 > 其他分享> 文章详细

PAT_A 1041 Be Unique

2022-06-29 00:01:11  阅读:162  来源: 互联网

标签:bets 1041 PAT int 31 Sample 88 Unique


PAT_A 1041 Be Unique

分析

建立对应的关系按要求统计分析即可满足题目的要求。

PAT_A 1041 Be Unique

题目的描述

Being unique is so important to people on Mars that even their lottery is designed in a unique way. The rule of winning is simple: one bets on a number chosen from [1,104]. The first one who bets on a unique number wins. For example, if there are 7 people betting on { 5 31 5 88 67 88 17 }, then the second one who bets on 31 wins.

Input Specification:

Each input file contains one test case. Each case contains a line which begins with a positive integer N (≤105) and then followed by N bets. The numbers are separated by a space.

Output Specification:

For each test case, print the winning number in a line. If there is no winner, print None instead.

Sample Input 1:

7 5 31 5 88 67 88 17

Sample Output 1:

31

Sample Input 2:

5 888 666 666 888 888

Sample Output 2:

None

AC的代码

#include<bits/stdc++.h>

using namespace std;
int n, k=0, mp[100005]={0}, nums[100005]={0};
int main(){

    cin>>n;
    for(int i=0;i<n;i++){
        int t;
        cin>>t;
        mp[t]++;
        nums[k++]=t;
    }
    for(int i=0; i<k; i++){
        if(mp[nums[i]]==1){
            cout<<nums[i]<<endl;
            return 0;
        }
    }
    cout<<"None"<<endl;
    return 0;
}

标签:bets,1041,PAT,int,31,Sample,88,Unique
来源: https://www.cnblogs.com/ghosteq/p/16421741.html

本站声明: 1. iCode9 技术分享网(下文简称本站)提供的所有内容,仅供技术学习、探讨和分享;
2. 关于本站的所有留言、评论、转载及引用,纯属内容发起人的个人观点,与本站观点和立场无关;
3. 关于本站的所有言论和文字,纯属内容发起人的个人观点,与本站观点和立场无关;
4. 本站文章均是网友提供,不完全保证技术分享内容的完整性、准确性、时效性、风险性和版权归属;如您发现该文章侵犯了您的权益,可联系我们第一时间进行删除;
5. 本站为非盈利性的个人网站,所有内容不会用来进行牟利,也不会利用任何形式的广告来间接获益,纯粹是为了广大技术爱好者提供技术内容和技术思想的分享性交流网站。

专注分享技术,共同学习,共同进步。侵权联系[81616952@qq.com]

Copyright (C)ICode9.com, All Rights Reserved.

ICode9版权所有