ICode9

精准搜索请尝试: 精确搜索
首页 > 其他分享> 文章详细

1019 General Palindromic Number(20分)

2022-06-02 15:32:15  阅读:121  来源: 互联网

标签:20 Palindromic palindromic number Number Sample base numbers Input


A number that will be the same when it is written forwards or backwards is known as a Palindromic Number. For example, 1234321 is a palindromic number. All single digit numbers are palindromic numbers.

Although palindromic numbers are most often considered in the decimal system, the concept of palindromicity can be applied to the natural numbers in any numeral system. Consider a number N>0 in base b≥2, where it is written in standard notation with k+1 digits ai​ as ∑i=0k​(ai​bi). Here, as usual, 0≤ai​<b for all i and ak​ is non-zero. Then N is palindromic if and only if ai​=ak−i​ for all i. Zero is written 0 in any base and is also palindromic by definition.

Given any positive decimal integer N and a base b, you are supposed to tell if N is a palindromic number in base b.

Input Specification:

Each input file contains one test case. Each case consists of two positive numbers N and b, where 0<N≤109 is the decimal number and 2≤b≤109 is the base. The numbers are separated by a space.

Output Specification:

For each test case, first print in one line Yes if N is a palindromic number in base b, or No if not. Then in the next line, print N as the number in base b in the form "ak​ ak−1​ ... a0​". Notice that there must be no extra space at the end of output.

Sample Input 1:

27 2

Sample Output 1:

Yes
1 1 0 1 1

Sample Input 2:

121 5

Sample Output 2:

No
4 4 1
#include<bits/stdc++.h>
using namespace std;

bool judge(vector<int> v){
   for (int i=0;i<v.size()/2;++i){
        if (v[i]!=v[v.size()-1-i]){
            return false;
        }
    }
    return true;
}
int main(){
    int n,b;
    cin>>n>>b;
    vector<int> v;
    while(n){
        v.push_back(n%b);
        n/=b;
    }
    if (judge(v)){
        cout<<"Yes"<<endl;
    }
    else
        cout<<"No"<<endl;
    for (int i=v.size()-1;i>=0;--i){
        cout<<v[i];
        if (i!=0){
            cout<<" ";
        }
    }
        
}

 

标签:20,Palindromic,palindromic,number,Number,Sample,base,numbers,Input
来源: https://www.cnblogs.com/coderhrz/p/16337881.html

本站声明: 1. iCode9 技术分享网(下文简称本站)提供的所有内容,仅供技术学习、探讨和分享;
2. 关于本站的所有留言、评论、转载及引用,纯属内容发起人的个人观点,与本站观点和立场无关;
3. 关于本站的所有言论和文字,纯属内容发起人的个人观点,与本站观点和立场无关;
4. 本站文章均是网友提供,不完全保证技术分享内容的完整性、准确性、时效性、风险性和版权归属;如您发现该文章侵犯了您的权益,可联系我们第一时间进行删除;
5. 本站为非盈利性的个人网站,所有内容不会用来进行牟利,也不会利用任何形式的广告来间接获益,纯粹是为了广大技术爱好者提供技术内容和技术思想的分享性交流网站。

专注分享技术,共同学习,共同进步。侵权联系[81616952@qq.com]

Copyright (C)ICode9.com, All Rights Reserved.

ICode9版权所有