ICode9

精准搜索请尝试: 精确搜索
首页 > 其他分享> 文章详细

Error: Package: 1:openssl-devel-1.0.2k-19.el7.x86_64 (base) Requires: openssl-libs(x86-64

2022-05-11 11:01:17  阅读:47  来源: 互联网

标签:1.0 x86 openssl devel 64 el7


假如我们在centos7上安装nginx时,会附带的安装一个openssl-devel的包,但是我们安装的时候会出现以下报错:可能是因为openssl-devel的版本太低。

Error: Package: 1:openssl-devel-1.0.1e-60.el7.x86_64 (base)
           Requires: openssl-libs(x86-64) = 1:1.0.1e-60.el7
           Installed: 1:openssl-libs-1.0.2k-21.el7_9.x86_64 (@updates)
               openssl-libs(x86-64) = 1:1.0.2k-21.el7_9
           Available: 1:openssl-libs-1.0.1e-60.el7.x86_64 (base)
               openssl-libs(x86-64) = 1:1.0.1e-60.el7
 You could try using --skip-broken to work around the problem
 You could try running: rpm -Va --nofiles --nodigest


**解决方法:**

1.如果虚拟机联网,直接安装

[root@proxy-master ~]# wget ftp://ftp.pbone.net/mirror/ftp.centos.org/7.9.2009/updates/x86_64/Packages/openssl-devel-1.0.2k-21.el7_9.x86_64.rpm

2.如果虚拟机没有联网,我们可以在迅雷里面下载然后传入虚拟机

http://rpm.pbone.net/resultsb_dist_94_size_1581144_name_openssl-devel-1.0.2k-21.el7_9.x86_64.rpm.html

然后安装

[root@rs1 ~]# rpm -ivh openssl-devel-1.0.2k-21.el7_9.x86_64.rpm

如果提示以下报错

[root@rs1 ~]# rpm -ivh openssl-devel-1.0.2k-21.el7_9.x86_64.rpm 
error: Failed dependencies:
    krb5-devel(x86-64) is needed by openssl-devel-1:1.0.2k-21.el7_9.x86_64
    zlib-devel(x86-64) is needed by openssl-devel-1:1.0.2k-21.el7_9.x86_64

说明没有下面的两个包, 直接安装下面的两个包,

[root@rs1 ~]# yum -y install krb5-devel zlib-devel

然后更新一样openssl-devel包

[root@rs1 ~]# rpm -ivh openssl-devel-1.0.2k-21.el7_9.x86_64.rpm --force

然后再次尝试安装一开始安装失败的软件包,发现成功。

标签:1.0,x86,openssl,devel,64,el7
来源: https://www.cnblogs.com/gaoqinghui/p/16257045.html

专注分享技术,共同学习,共同进步。侵权联系[admin#icode9.com]

Copyright (C)ICode9.com, All Rights Reserved.

ICode9版权所有