ICode9

精准搜索请尝试: 精确搜索
首页 > 其他分享> 文章详细

在提取 Docker 映像时解决“未找到清单”错误

2022-03-21 17:01:22  阅读:67  来源: 互联网

标签:尝试 标签 映像 4.39 未找到 版本 Docker


Pulling ghost (ghost:4.39.0)...
ERROR: manifest for ghost:4.39.0 not found: manifest unknown: manifest unknown

如果您尝试拉取 Docker 映像并且它显示未找到清单错误,那么您需要了解如何解决它。

清单未知,因为没有这样的 Docker 映像

这是几乎所有涉及此错误的情况的根本原因,您尝试提取的特定 docker 映像不存在。

这怎么可能?这可能有几个原因。

  • 您在使用 Docker 映像的特定标签或版本时打错了字,例如,如果它是 20.04 版本并且您键入 20.4,它将找不到图像。
  • 您尝试下载 Docker 映像中尚不可用的版本,例如,在我的例子中,Ghost 版本 4.39 已发布,但最新的 Docker 映像仍被标记为版本 4.38.1。
  • 如果您尝试从私有存储库下载,您可能需要先登录:docker login repository_details

基本上,您应该仔细检查您尝试从存储库中提取的 Docker 映像的名称和标签。

例如,在获取 Docker 镜像时使用 latest 标签是很常见的,但有些镜像甚至可能没有 latest 标签(这种情况很少见,但也有可能)。

如果您从Docker Hub中提取镜像(像大多数人一样),您可以转到其 Web 界面并查看名称和可用标签。

我希望这可以帮助您解决 Docker 的未知清单错误,如果您仍有任何疑问,请随时在下方发表评论。

标签:尝试,标签,映像,4.39,未找到,版本,Docker
来源: https://blog.csdn.net/weixin_43025343/article/details/123640031

专注分享技术,共同学习,共同进步。侵权联系[81616952@qq.com]

Copyright (C)ICode9.com, All Rights Reserved.

ICode9版权所有