ICode9

精准搜索请尝试: 精确搜索
首页 > 其他分享> 文章详细

1114 Family Property (25 分)(并查集)

2022-03-02 16:02:05  阅读:193  来源: 互联网

标签:25 family area int 查集 ID Property Data id


This time, you are supposed to help us collect the data for family-owned property. Given each person's family members, and the estate(房产)info under his/her own name, we need to know the size of each family, and the average area and number of sets of their real estate.

Input Specification:

Each input file contains one test case. For each case, the first line gives a positive integer N (<=1000). Then N lines follow, each gives the infomation of a person who owns estate in the format:

ID Father Mother k Child1 ... Childk M_estate Area

where ID is a unique 4-digit identification number for each person; Father and Mother are the ID's of this person's parents (if a parent has passed away, -1 will be given instead); k (0<=k<=5) is the number of children of this person; Childi's are the ID's of his/her children; M_estate is the total number of sets of the real estate under his/her name; and Area is the total area of his/her estate.

Output Specification:

For each case, first print in a line the number of families (all the people that are related directly or indirectly are considered in the same family). Then output the family info in the format:

ID M AVG_sets AVG_area

where ID is the smallest ID in the family; M is the total number of family members; AVG_sets is the average number of sets of their real estate; and AVG_area is the average area. The average numbers must be accurate up to 3 decimal places. The families must be given in descending order of their average areas, and in ascending order of the ID’s if there is a tie.

Sample Input:

10
6666 5551 5552 1 7777 1 100
1234 5678 9012 1 0002 2 300
8888 -1 -1 0 1 1000
2468 0001 0004 1 2222 1 500
7777 6666 -1 0 2 300
3721 -1 -1 1 2333 2 150
9012 -1 -1 3 1236 1235 1234 1 100
1235 5678 9012 0 1 50
2222 1236 2468 2 6661 6662 1 300
2333 -1 3721 3 6661 6662 6663 1 100

Sample Output:

3
8888 1 1.000 1000.000
0001 15 0.600 100.000
5551 4 0.750 100.000

题目大意:

给定每个人的家庭成员和其自己名下的房产,请你统计出每个家庭的人口数、人均房产面积及房产套数。首先在第一行输出家庭个数(所有有亲属关系的人都属于同一个家庭)。随后按下列格式输出每个家庭的信息:家庭成员的最小编号 家庭人口数 人均房产套数 人均房产面积。其中人均值要求保留小数点后3位。家庭信息首先按人均面积降序输出,若有并列,则按成员编号的升序输出

分析:

用并查集。分别用两个结构体数组,一个data用来接收数据,接收的时候顺便实现了并查集的操作union,另一个数组ans用来输出最后的答案,因为要计算家庭人数,所以用visit标记所有出现过的结点,对于每个结点的父结点,people++统计人数。标记flag == true,计算true的个数cnt就可以知道一共有多少个家庭。排序后输出前cnt个就是所求答案~~

原文链接:https://blog.csdn.net/liuchuo/article/details/52200109

题解

#include <bits/stdc++.h>

using namespace std;
struct Data
{
    int id,fid,mid,num,area;
    int cid[10];
}Data[1005];
struct node
{
    int id,people;
    double num,area;
    bool flag=false;
}ans[10000];
int father[10000],vis[10000];
int findFather(int x){
    while(x!=father[x]){
        x=father[x];
    }
    return x;
}
void Union(int a,int b){
    int faA=findFather(a);
    int faB=findFather(b);
    if(faA>faB)
        father[faA]=faB;
    else if(faA<faB)
        father[faB]=faA;
}
bool cmp(node a,node b){
    if(a.area!=b.area) return a.area>b.area;
    else return a.id<b.id;
}
int main()
{
#ifdef ONLINE_JUDGE
#else
    freopen("1.txt", "r", stdin);
#endif
    int n,k;
    cin>>n;
    for(int i=0;i<10000;i++){
        father[i]=i;
    }
    for(int i=0;i<n;i++){
        cin>>Data[i].id>>Data[i].fid>>Data[i].mid>>k;
        vis[Data[i].id]=true;
        if(Data[i].fid!=-1){
            Union(Data[i].id,Data[i].fid);
            vis[Data[i].fid];
        }
        if(Data[i].mid!=-1){
            Union(Data[i].id,Data[i].mid);
            vis[Data[i].mid];
        }
        for(int j=0;j<k;j++){
            cin>>Data[i].cid[j];
            Union(Data[i].id,Data[i].cid[j]);
            vis[Data[i].cid[j]]=true;
        }
        cin>>Data[i].num>>Data[i].area;
    }
    for(int i=0;i<n;i++){
        int id=findFather(Data[i].id);
        ans[id].id=id;
        ans[id].num+=Data[i].num;
        ans[id].area+=Data[i].area;
        ans[id].flag=true;
    }
    int cnt=0;
    for(int i=0;i<10000;i++){
        if(vis[i]=true)
            ans[findFather(i)].people++;
        if(ans[i].flag==true)
            cnt++;
    }
    for(int i=0;i<10000;i++){
        if(ans[i].flag){
            ans[i].num=(double)(ans[i].num*1.0/ans[i].people);
            ans[i].area=(double)(ans[i].area*1.0/ans[i].people);
        }
    }
    sort(ans,ans+10000,cmp);
    cout<<cnt<<endl;
    for(int i=0;i<cnt;i++){
        printf("%04d %d %.3f %.3f\n",ans[i].id,ans[i].people,ans[i].num,ans[i].area);
    }
    return 0;
}

标签:25,family,area,int,查集,ID,Property,Data,id
来源: https://www.cnblogs.com/moonlight1999/p/15955526.html

本站声明: 1. iCode9 技术分享网(下文简称本站)提供的所有内容,仅供技术学习、探讨和分享;
2. 关于本站的所有留言、评论、转载及引用,纯属内容发起人的个人观点,与本站观点和立场无关;
3. 关于本站的所有言论和文字,纯属内容发起人的个人观点,与本站观点和立场无关;
4. 本站文章均是网友提供,不完全保证技术分享内容的完整性、准确性、时效性、风险性和版权归属;如您发现该文章侵犯了您的权益,可联系我们第一时间进行删除;
5. 本站为非盈利性的个人网站,所有内容不会用来进行牟利,也不会利用任何形式的广告来间接获益,纯粹是为了广大技术爱好者提供技术内容和技术思想的分享性交流网站。

专注分享技术,共同学习,共同进步。侵权联系[81616952@qq.com]

Copyright (C)ICode9.com, All Rights Reserved.

ICode9版权所有