ICode9

精准搜索请尝试: 精确搜索
首页 > 其他分享> 文章详细

1064 Complete Binary Search Tree (30 分)

2022-02-27 19:04:48  阅读:243  来源: 互联网

标签:node Binary Search Complete BL int keys line root


A Binary Search Tree (BST) is recursively defined as a binary tree which has the following properties:

  • The left subtree of a node contains only nodes with keys less than the node's key.
  • The right subtree of a node contains only nodes with keys greater than or equal to the node's key.
  • Both the left and right subtrees must also be binary search trees.

A Complete Binary Tree (CBT) is a tree that is completely filled, with the possible exception of the bottom level, which is filled from left to right.

Now given a sequence of distinct non-negative integer keys, a unique BST can be constructed if it is required that the tree must also be a CBT. You are supposed to output the level order traversal sequence of this BST.

Input Specification:

Each input file contains one test case. For each case, the first line contains a positive integer N (≤1000). Then N distinct non-negative integer keys are given in the next line. All the numbers in a line are separated by a space and are no greater than 2000.

Output Specification:

For each test case, print in one line the level order traversal sequence of the corresponding complete binary search tree. All the numbers in a line must be separated by a space, and there must be no extra space at the end of the line.

Sample Input:

10
1 2 3 4 5 6 7 8 9 0

Sample Output:

6 3 8 1 5 7 9 0 2 4

代码: 

#include<iostream>
#include<queue>
#include<algorithm>
#include<cmath>
using namespace std;
int N,count1=0;
vector<int > keys;
struct node
{
    int data;
    node* lchild;
    node* rchild;
};
node* creat(int L,int R)
{
    if(L>R)
        return NULL;
    int n=R-L+1;
    int h=ceil(log(n+1)/log(2));
    int bottom=n-pow(2,h-1)+1,BL;
    if(bottom>pow(2,h-1)/2)
        BL=pow(2,h-1)/2;
    else
        BL=bottom;
    int SL=(pow(2,h-1)-2)/2+BL;
    node *root=new node;
    root->data=keys[L+SL];
    root->lchild=creat(L,L+SL-1);
    root->rchild=creat(L+SL+1,R);
    return root;
}
void levelorder(node* root)
{
    queue<node *> Q;
    if(root==NULL)
        return;
    Q.push(root);
    while(!Q.empty())
    {
        node *p=Q.front();
        Q.pop();
        count1++;
        if(count1==1)
             printf("%d",p->data);
        else
            printf(" %d",p->data);
        if(p->lchild!=NULL)
            Q.push(p->lchild);
        if(p->rchild!=NULL)
            Q.push(p->rchild);
    }
}
int main()
{
    scanf("%d",&N);
    int temp;
    for(int i=0;i<N;i++)
    {
        scanf("%d",&temp);
        keys.push_back(temp);
    }
    sort(keys.begin(),keys.end());
    node* root=creat(0,N-1);
    levelorder(root);
    return 0;
}

 

标签:node,Binary,Search,Complete,BL,int,keys,line,root
来源: https://blog.csdn.net/fairylyt/article/details/123168270

本站声明: 1. iCode9 技术分享网(下文简称本站)提供的所有内容,仅供技术学习、探讨和分享;
2. 关于本站的所有留言、评论、转载及引用,纯属内容发起人的个人观点,与本站观点和立场无关;
3. 关于本站的所有言论和文字,纯属内容发起人的个人观点,与本站观点和立场无关;
4. 本站文章均是网友提供,不完全保证技术分享内容的完整性、准确性、时效性、风险性和版权归属;如您发现该文章侵犯了您的权益,可联系我们第一时间进行删除;
5. 本站为非盈利性的个人网站,所有内容不会用来进行牟利,也不会利用任何形式的广告来间接获益,纯粹是为了广大技术爱好者提供技术内容和技术思想的分享性交流网站。

专注分享技术,共同学习,共同进步。侵权联系[81616952@qq.com]

Copyright (C)ICode9.com, All Rights Reserved.

ICode9版权所有