ICode9

精准搜索请尝试: 精确搜索
首页 > 其他分享> 文章详细

1122 Hamiltonian Cycle (25 分)(图论)

2022-02-27 11:04:05  阅读:184  来源: 互联网

标签:25 NO int 1122 Hamiltonian num flag2 Cycle cycle


The "Hamilton cycle problem" is to find a simple cycle that contains every vertex in a graph. Such a cycle is called a "Hamiltonian cycle".

In this problem, you are supposed to tell if a given cycle is a Hamiltonian cycle.

Input Specification:

Each input file contains one test case. For each case, the first line contains 2 positive integers N (2< N <= 200), the number of vertices, and M, the number of edges in an undirected graph. Then M lines follow, each describes an edge in the format "Vertex1 Vertex2", where the vertices are numbered from 1 to N. The next line gives a positive integer K which is the number of queries, followed by K lines of queries, each in the format:

n V1 V2 ... Vn

where n is the number of vertices in the list, and Vi's are the vertices on a path.

Output Specification:

For each query, print in a line "YES" if the path does form a Hamiltonian cycle, or "NO" if not.

Sample Input:

6 10
6 2
3 4
1 5
2 5
3 1
4 1
1 6
6 3
1 2
4 5
6
7 5 1 4 3 6 2 5
6 5 1 4 3 6 2
9 6 2 1 6 3 4 5 2 6
4 1 2 5 1
7 6 1 3 4 5 2 6
7 6 1 2 5 4 3 1

Sample Output:

YES
NO
NO
NO
YES
NO

题目大意:

给出一个图,判断给定的路径是不是哈密尔顿路径

分析:

1.设置falg1 判断节点是否多走、少走、或走成环
2.设置flag2 判断这条路能不能走通
3.当falg1、flag2都为1时是哈密尔顿路径,否则不是

原文链接:https://blog.csdn.net/liuchuo/article/details/53572051

题解

#include <bits/stdc++.h>

using namespace std;
int n,m;
int G[210][210];
int main()
{
#ifdef ONLINE_JUDGE
#else
    freopen("1.txt", "r", stdin);
#endif
    int a,b;
    cin>>n>>m;
    for(int i=0;i<m;i++){
        cin>>a>>b;
        G[a][b]=1;
        G[b][a]=1;
    }
    int k,num;
    cin>>k;
    while(k--){
        bool flag1=true,flag2=true;
        cin>>num;
        vector<int> v(num);
        set<int> s;
        for(int i=0;i<num;i++){
            cin>>v[i];
            s.insert(v[i]);
        }
        if(s.size()!=n||n!=num-1||v[0]!=v[num-1]) flag1=false;
        for(int i=0;i<num-1;i++)
            if(G[v[i]][v[i+1]]==0) flag2=false;
        printf("%s",flag1 && flag2 ? "YES\n" : "NO\n");
    }
    return 0;
}

标签:25,NO,int,1122,Hamiltonian,num,flag2,Cycle,cycle
来源: https://www.cnblogs.com/moonlight1999/p/15941701.html

本站声明: 1. iCode9 技术分享网(下文简称本站)提供的所有内容,仅供技术学习、探讨和分享;
2. 关于本站的所有留言、评论、转载及引用,纯属内容发起人的个人观点,与本站观点和立场无关;
3. 关于本站的所有言论和文字,纯属内容发起人的个人观点,与本站观点和立场无关;
4. 本站文章均是网友提供,不完全保证技术分享内容的完整性、准确性、时效性、风险性和版权归属;如您发现该文章侵犯了您的权益,可联系我们第一时间进行删除;
5. 本站为非盈利性的个人网站,所有内容不会用来进行牟利,也不会利用任何形式的广告来间接获益,纯粹是为了广大技术爱好者提供技术内容和技术思想的分享性交流网站。

专注分享技术,共同学习,共同进步。侵权联系[81616952@qq.com]

Copyright (C)ICode9.com, All Rights Reserved.

ICode9版权所有