ICode9

精准搜索请尝试: 精确搜索
首页 > 其他分享> 文章详细

Knight Moves

2022-01-23 16:02:40  阅读:161  来源: 互联网

标签:startx starty point int Knight tail knight Moves


Description

Background
Mr Somurolov, fabulous chess-gamer indeed, asserts that no one else but him can move knights from one position to another so fast. Can you beat him?
The Problem
Your task is to write a program to calculate the minimum number of moves needed for a knight to reach one point from another, so that you have the chance to be faster than Somurolov.
For people not familiar with chess, the possible knight moves are shown in Figure 1.

Input

The input begins with the number n of scenarios on a single line by itself.
Next follow n scenarios. Each scenario consists of three lines containing integer numbers. The first line specifies the length l of a side of the chess board (4 <= l <= 300). The entire board has size l * l. The second and third line contain pair of integers {0, ..., l-1}*{0, ..., l-1} specifying the starting and ending position of the knight on the board. The integers are separated by a single blank. You can assume that the positions are valid positions on the chess board of that scenario.

Output

For each scenario of the input you have to calculate the minimal amount of knight moves which are necessary to move from the starting point to the ending point. If starting point and ending point are equal,distance is zero. The distance must be written on a single line.

Sample Input

3
8
0 0
7 0
100
0 0
30 50
10
1 1
1 1

Sample Output

5
28
0

思路:

BFS,广搜

由于这是广搜,所以第一次判断出到达终点的步数就是最小的。

#include<iostream>
#include<string.h>
using namespace std;
#define N 300
bool v[N][N];
struct point
{
	int x;//行号 
	int y;//列号 
	int step;//步数 
}point[100000];
int d[8][2]={{-2,1},{-1,2},{1,2},{2,1},{2,-1},{1,-2},{-1,-2},{-2,-1}};//偏移数组 
int main()
{
	int n;
	scanf("%d",&n);
	while(n--)
	{
		int L,startx,starty,p,q;//startx,stary起点坐标,p,q终点坐标 
		scanf("%d\n%d %d\n%d %d",&L,&startx,&starty,&p,&q);
		//BFS
		//对起点start初始化 
		int head=1;
		int tail=1;
		memset(v,0,sizeof(v));//赋值0 
		v[startx][starty]=1; 
		point[tail].x =startx;
		point[tail].y =starty;
		point[tail].step =0;
		tail++;
		while(head<tail)//如果不符合就是点相同 
		{
			//使x,y分别为队首元素的行号和列号
			int x=point[head].x;
			int y=point[head].y;
			int step=point[head].step;
			//到终点的情况
			if(x==p&&y==q)
			{
				printf("%d\n",step);
				break;
			}
			//进行八个方向试探
			for(int k=0;k<8;k++)
			{
				//tx,ty是试探的点
				int tx,ty;
				tx=x+d[k][0];
				ty=y+d[k][1];
				//当试探的点未访问时
				if(tx>=0&&tx<L&&ty>=0&&ty<L&&v[tx][ty]==0)
				{
					//将该试探点入队
					v[tx][ty]=1;
					point[tail].x=tx;
					point[tail].y=ty;
					point[tail].step=step+1;
					tail++;
				} 
			}
			head++;
		} 
	}
	return 0;
}

标签:startx,starty,point,int,Knight,tail,knight,Moves
来源: https://blog.csdn.net/TherAndI/article/details/122652356

本站声明: 1. iCode9 技术分享网(下文简称本站)提供的所有内容,仅供技术学习、探讨和分享;
2. 关于本站的所有留言、评论、转载及引用,纯属内容发起人的个人观点,与本站观点和立场无关;
3. 关于本站的所有言论和文字,纯属内容发起人的个人观点,与本站观点和立场无关;
4. 本站文章均是网友提供,不完全保证技术分享内容的完整性、准确性、时效性、风险性和版权归属;如您发现该文章侵犯了您的权益,可联系我们第一时间进行删除;
5. 本站为非盈利性的个人网站,所有内容不会用来进行牟利,也不会利用任何形式的广告来间接获益,纯粹是为了广大技术爱好者提供技术内容和技术思想的分享性交流网站。

专注分享技术,共同学习,共同进步。侵权联系[81616952@qq.com]

Copyright (C)ICode9.com, All Rights Reserved.

ICode9版权所有