ICode9

精准搜索请尝试: 精确搜索
首页 > 其他分享> 文章详细

1090 Highest Price in Supply Chain (25 分)(树的遍历)

2022-01-11 11:03:12  阅读:198  来源: 互联网

标签:25 结点 1090 Chain int price maxDepth 深度 supplier


A supply chain is a network of retailers(零售商), distributors(经销商), and suppliers(供应商)-- everyone involved in moving a product from supplier to customer.

Starting from one root supplier, everyone on the chain buys products from one's supplier in a price P and sell or distribute them in a price that is r% higher than P. It is assumed that each member in the supply chain has exactly one supplier except the root supplier, and there is no supply cycle.

Now given a supply chain, you are supposed to tell the highest price we can expect from some retailers.

Input Specification:

Each input file contains one test case. For each case, The first line contains three positive numbers: N (<=105), the total number of the members in the supply chain (and hence they are numbered from 0 to N-1); P, the price given by the root supplier; and r, the percentage rate of price increment for each distributor or retailer. Then the next line contains N numbers, each number Si is the index of the supplier for the i-th member. Sroot for the root supplier is defined to be -1. All the numbers in a line are separated by a space.

Output Specification:

For each test case, print in one line the highest price we can expect from some retailers, accurate up to 2 decimal places, and the number of retailers that sell at the highest price. There must be one space between the two numbers. It is guaranteed that the price will not exceed 1010.

Sample Input:

9 1.80 1.00
1 5 4 4 -1 4 5 3 6

Sample Output:

1.85 2

题目大意:

给一棵树,在树根处货物的价格为p,然后每往下走一层,价格增加r%,求所有叶子结点的最高价格,以及这个价格的叶子结点个数~

分析:

用二维数组v[i][j]存储,对于每一个结点i,它的孩子结点的下标push_back存储在v[i]中。用深度优先搜索dfs,保存当前结点的下标index以及当前结点所在层数,当 当前结点的孩子结点个数为0的时候说明是叶子结点,更新maxdepth和maxnum的值,最后输出~

注意:

如果采用保存某个结点的父结点的下标的形式,然后一直遍历到根结点的深度/广度优先,会出现三个超时。因为从叶子结点往上遍历将会把所有路径都走一遍,很多都是重复走的路径,会超时,没有从根结点往下遍历的方式快~~
记得r是百分比,要除以100之后再计算复利~

原文链接:https://blog.csdn.net/liuchuo/article/details/52206430

题解

子结点:0 1 2 3  4 5 6 7 8 
父结点:1 5 4 4 -1 4 5 3 6

image
image
image

#include <bits/stdc++.h>

using namespace std;
const int maxn=100010;
vector<int> child[maxn];
double p,r;
int n,maxDepth=0,num=0;
void DFS(int index,int depth){
    if(child[index].size()==0){ //到达叶节点
        if(depth>maxDepth){     //深度比最大深度大
            maxDepth=depth;     //更新最大深度
            num=1;              //重置最大深度的叶节点个数为1
        }else if(depth==maxDepth){ //深度等于最大深度
            num++;                 //最大深度的叶节点个数加1
        }
        return;
    }
    for(int i=0;i<child[index].size();i++)
        DFS(child[index][i],depth+1); //递归访问结点index的子结点
}
int main()
{
#ifdef ONLINE_JUDGE
#else
    freopen("1.txt", "r", stdin);
#endif
    int father,root;
    cin>>n>>p>>r;
    r/=100;
    for(int i=0;i<n;i++){
        cin>>father;
        if(father!=-1){
            child[father].push_back(i);
        }else root=i;
    }
    DFS(root,0);
    printf("%.2f %d\n",p*pow(1+r,maxDepth),num);
    return 0;
}

标签:25,结点,1090,Chain,int,price,maxDepth,深度,supplier
来源: https://www.cnblogs.com/moonlight1999/p/15768735.html

本站声明: 1. iCode9 技术分享网(下文简称本站)提供的所有内容,仅供技术学习、探讨和分享;
2. 关于本站的所有留言、评论、转载及引用,纯属内容发起人的个人观点,与本站观点和立场无关;
3. 关于本站的所有言论和文字,纯属内容发起人的个人观点,与本站观点和立场无关;
4. 本站文章均是网友提供,不完全保证技术分享内容的完整性、准确性、时效性、风险性和版权归属;如您发现该文章侵犯了您的权益,可联系我们第一时间进行删除;
5. 本站为非盈利性的个人网站,所有内容不会用来进行牟利,也不会利用任何形式的广告来间接获益,纯粹是为了广大技术爱好者提供技术内容和技术思想的分享性交流网站。

专注分享技术,共同学习,共同进步。侵权联系[81616952@qq.com]

Copyright (C)ICode9.com, All Rights Reserved.

ICode9版权所有