ICode9

精准搜索请尝试: 精确搜索
首页 > 其他分享> 文章详细

UVA839 Not so Mobile【递归树】

2019-02-28 13:03:55  阅读:288  来源: 互联网

标签:Wl Mobile wl UVA839 mobile flag so wr Wr


Before being an ubiquous communications gadget, a mobile was just a structure made of strings and wires suspending colourfull things. This kind of mobile is usually found hanging over cradles of small babies.

    The figure illustrates a simple mobile. It is just a wire, suspended by a string, with an object on each side. It can also be seen as a kind of lever with the fulcrum on the point where the string ties the wire. From the lever principle we know that to balance a simple mobile the product of the weight of the objects by their distance to the fulcrum must be equal. That is Wl × Dl = Wr × Dr where Dl is the left distance, Dr is the right distance, Wl is the left weight and Wr is the right weight.
    In a more complex mobile the object may be replaced by a sub-mobile, as shown in the next figure. In this case it is not so straightforward to check if the mobile is balanced so we need you to write a program that, given a description of a mobile as input, checks whether the mobile is in equilibrium or not.

Input
The input begins with a single positive integer on a line by itself indicating the number of the cases following, each of them as described below. This line is followed by a blank line, and there is also a blank line between two consecutive inputs.
    The input is composed of several lines, each containing 4 integers separated by a single space. The 4 integers represent the distances of each object to the fulcrum and their weights, in the format: Wl Dl Wr Dr
    If Wl or Wr is zero then there is a sub-mobile hanging from that end and the following lines define the the sub-mobile. In this case we compute the weight of the sub-mobile as the sum of weights of all its objects, disregarding the weight of the wires and strings. If both Wl and Wr are zero then the following lines define two sub-mobiles: first the left then the right one.
Output
For each test case, the output must follow the description below. The outputs of two consecutive cases will be separated by a blank line.
    Write ‘YES’ if the mobile is in equilibrium, write ‘NO’ otherwise.
Sample Input
1
0 2 0 4
0 3 0 1
1 1 1 1
2 4 4 2
1 6 3 2
Sample Output
YES

问题链接UVA839 Not so Mobile
问题简述
    给定一个杠杆两端的物体的质量和力臂,如果质量为零,则下面是一个杠杆,判断是否所有杠杆平衡。
问题分析
    本来是一个树的平衡问题,用递归来解决比较简单。这里的解题递归程序可以看作是在创建递归树,原理上与建树是相同的。
程序说明:(略)
参考链接:(略)
题记:(略)

AC的C++程序如下:

/* UVA839 Not so Mobile */

#include <bits/stdc++.h>

using namespace std;

// 递归程序:输入并且判定平衡
int tree(bool& flag)
{
    int wl, dl, wr, dr;
    scanf("%d%d%d%d", &wl, &dl, &wr, &dr);
    if (!wl) wl = tree(flag);
    if (!wr) wr = tree(flag);
    flag = wl * dl == wr * dr ? flag : false;
    return wl + wr;
}

int main()
{
    int t;
    scanf("%d", &t);
    while(t--) {
        bool flag = true;
        tree(flag);
        printf("%s\n", flag ? "YES" : "NO");
        if(t) printf("\n");
    }

    return 0;
}

标签:Wl,Mobile,wl,UVA839,mobile,flag,so,wr,Wr
来源: https://www.cnblogs.com/tigerisland45/p/10449650.html

本站声明: 1. iCode9 技术分享网(下文简称本站)提供的所有内容,仅供技术学习、探讨和分享;
2. 关于本站的所有留言、评论、转载及引用,纯属内容发起人的个人观点,与本站观点和立场无关;
3. 关于本站的所有言论和文字,纯属内容发起人的个人观点,与本站观点和立场无关;
4. 本站文章均是网友提供,不完全保证技术分享内容的完整性、准确性、时效性、风险性和版权归属;如您发现该文章侵犯了您的权益,可联系我们第一时间进行删除;
5. 本站为非盈利性的个人网站,所有内容不会用来进行牟利,也不会利用任何形式的广告来间接获益,纯粹是为了广大技术爱好者提供技术内容和技术思想的分享性交流网站。

专注分享技术,共同学习,共同进步。侵权联系[81616952@qq.com]

Copyright (C)ICode9.com, All Rights Reserved.

ICode9版权所有