ICode9

精准搜索请尝试: 精确搜索
首页 > 其他分享> 文章详细

Oil Deposits

2021-11-17 22:33:33  阅读:159  来源: 互联网

标签:plot Oil int Deposits deposits oil grid pockets


链接:
题目:
Problem Description
The GeoSurvComp geologic survey company is responsible for detecting underground oil deposits. GeoSurvComp works with one large rectangular region of land at a time, and creates a grid that divides the land into numerous square plots. It then analyzes each plot separately, using sensing equipment to determine whether or not the plot contains oil. A plot containing oil is called a pocket. If two pockets are adjacent, then they are part of the same oil deposit. Oil deposits can be quite large and may contain numerous pockets. Your job is to determine how many different oil deposits are contained in a grid.

Input
The input file contains one or more grids. Each grid begins with a line containing m and n, the number of rows and columns in the grid, separated by a single space. If m = 0 it signals the end of the input; otherwise 1 <= m <= 100 and 1 <= n <= 100. Following this are m lines of n characters each (not counting the end-of-line characters). Each character corresponds to one plot, and is either '*', representing the absence of oil, or '@', representing an oil pocket.

Output
For each grid, output the number of distinct oil deposits. Two different pockets are part of the same oil deposit if they are adjacent horizontally, vertically, or diagonally. An oil deposit will not contain more than 100 pockets.

Sample Input
1 1
*
3 5
*@*@*
**@**
*@*@*
1 8
@@****@*
5 5
****@
*@@*@
*@**@
@@@*@
@@**@
0 0

Sample Output
0
1
2
2

#include<iostream>
using namespace std;

const int M=101,N=101;
char f[M][N];
int n,m,ans;

int bfs(int i,int j)
{
    if(i<0||i>=n||j<0||j>=m) //坐标不合法
        return 0;
    if(f[i][j]=='@')         //如果是油田 
    {
        f[i][j]='*';
        for(int q=-1;q<=1;q++)
            for(int w=-1;w<=1;w++)
                bfs(i+q,j+w);
    }
    return 0;
}

int main()
{
    while(cin>>n>>m)
    {
        if(!n&&!m) return 0;
        ans=0;
        for(int i=0;i<n;i++)
            for(int j=0;j<m;j++)
                cin>>f[i][j];
        for(int i=0;i<n;i++)
            for(int j=0;j<m;j++)
                if(f[i][j]=='@') 
                {
                    bfs(i,j);
                    ans++;
                }
        cout<<ans<<endl;
    }
    return 0;
}

标签:plot,Oil,int,Deposits,deposits,oil,grid,pockets
来源: https://www.cnblogs.com/longwind7/p/15569845.html

本站声明: 1. iCode9 技术分享网(下文简称本站)提供的所有内容,仅供技术学习、探讨和分享;
2. 关于本站的所有留言、评论、转载及引用,纯属内容发起人的个人观点,与本站观点和立场无关;
3. 关于本站的所有言论和文字,纯属内容发起人的个人观点,与本站观点和立场无关;
4. 本站文章均是网友提供,不完全保证技术分享内容的完整性、准确性、时效性、风险性和版权归属;如您发现该文章侵犯了您的权益,可联系我们第一时间进行删除;
5. 本站为非盈利性的个人网站,所有内容不会用来进行牟利,也不会利用任何形式的广告来间接获益,纯粹是为了广大技术爱好者提供技术内容和技术思想的分享性交流网站。

专注分享技术,共同学习,共同进步。侵权联系[81616952@qq.com]

Copyright (C)ICode9.com, All Rights Reserved.

ICode9版权所有