ICode9

精准搜索请尝试: 精确搜索
首页 > 其他分享> 文章详细

1004. Counting Leaves (30)-PAT甲级真题(bfs,dfs,树的遍历,层序遍历)

2021-11-17 22:03:52  阅读:195  来源: 互联网

标签:结点 遍历 leaf int max 叶子 PAT Counting ID


A family hierarchy is usually presented by a pedigree tree. Your job is to count those family members who have no child.

Input

Each input file contains one test case. Each case starts with a line containing 0 < N < 100, the number of nodes in a tree, and M (< N), the number of non-leaf nodes. Then M lines follow, each in the format:

ID K ID[1] ID[2] ... ID[K]

where ID is a two-digit number representing a given non-leaf node, K is the number of its children, followed by a sequence of two-digit ID's of its children. For the sake of simplicity, let us fix the root ID to be 01.

Output

For each test case, you are supposed to count those family members who have no child for every seniority level starting from the root. The numbers must be printed in a line, separated by a space, and there must be no extra space at the end of each line.

The sample case represents a tree with only 2 nodes, where 01 is the root and 02 is its only child. Hence on the root 01 level, there is 0 leaf node; and on the next level, there is 1 leaf node. Then we should output "0 1" in a line.

Sample Input

2 1
01 1 02

Sample Output

0 1

生词

英文 解释
family hierarchy 家庭等级
pedigree tree 族谱
The input ends with N being 0. 输入以N为0结束。
seniority 年长
every seniority level 每一层次

题目大意:

给出一棵树,问每一层各有多少个叶子结点~

分析:

可以用dfs也可以用bfs~如果用dfs,用二维数组保存每一个有孩子结点的结点以及他们的孩子结点,从根结点开始遍历,直到遇到叶子结点,就将当前层数depth的book[depth]++;标记第depth层拥有的叶子结点数,最后输出~
image

原文链接:https://blog.csdn.net/liuchuo/article/details/52214833

DFS题解

image

#include <bits/stdc++.h>

using namespace std;
const int N=110;

vector<int> G[N]; //存放树
int leaf[N]={0};  //存放每层的叶子结点个数
int max_h=1;      //树的深度

void DFS(int index,int h) //index为当前遍历到的结点编号,h为当前深度
{
    max_h=max(h,max_h);
    if(G[index].size()==0){ //如果该结点是叶子结点
        leaf[h]++;
        return;
    }
    for(int i=0;i<G[index].size();i++){ //枚举所有子结点
        DFS(G[index][i],h+1);
    }
}
int main()
{
#ifdef ONLINE_JUDGE
#else
    freopen("1.txt", "r", stdin);
#endif
    int n,m,parent,child,k;
    scanf("%d%d",&n,&m);
    for(int i=0;i<m;i++)
    {
        scanf("%d%d",&parent,&k);  //父结点编号及子结点个数
        for(int j=0;j<k;j++){
            scanf("%d",&child);
            G[parent].push_back(child);  //加边
        }
    }
    DFS(1,1); //初始入口为跟结点与第一层
    printf("%d",leaf[1]);
    for(int i=2;i<=max_h;i++){
        printf(" %d",leaf[i]);
    }
    return 0;
}

BFS题解

image

#include <bits/stdc++.h>

using namespace std;
const int N=110;

vector<int> G[N]; //存放树
int h[N];     //各结点所处的层号,从1开始
int leaf[N];  //存放每层的叶子结点个数
int max_h;      //树的最大深度

void BFS()
{
    queue<int> Q;
    Q.push(1);  //将根结点压入队列
    while(!Q.empty()){
        int id=Q.front(); //弹出队首结点
        Q.pop();
        max_h=max(max_h,h[id]); //更新最大深度
        if(G[id].size()==0){ //如果该结点是叶子结点
            leaf[h[id]]++;
        }
        for(int i=0;i<G[id].size();i++){ //枚举所有子结点
            h[G[id][i]]=h[id]+1;  //子结点编号为G[id][i]
            Q.push(G[id][i]);  //将子结点压入队列
        }
    }
}
int main()
{
#ifdef ONLINE_JUDGE
#else
    freopen("1.txt", "r", stdin);
#endif
    int n,m,parent,child,k;
    scanf("%d%d",&n,&m);
    for(int i=0;i<m;i++)
    {
        scanf("%d%d",&parent,&k);  //父结点编号及子结点个数
        for(int j=0;j<k;j++){
            scanf("%d",&child);
            G[parent].push_back(child);  //加边
        }
    }
    h[1]=1;  //初始化根节点
    BFS();   //BFS入口
    printf("%d",leaf[1]);
    for(int i=2;i<=max_h;i++){
        printf(" %d",leaf[i]);
    }
    return 0;
}

标签:结点,遍历,leaf,int,max,叶子,PAT,Counting,ID
来源: https://www.cnblogs.com/moonlight1999/p/15515346.html

本站声明: 1. iCode9 技术分享网(下文简称本站)提供的所有内容,仅供技术学习、探讨和分享;
2. 关于本站的所有留言、评论、转载及引用,纯属内容发起人的个人观点,与本站观点和立场无关;
3. 关于本站的所有言论和文字,纯属内容发起人的个人观点,与本站观点和立场无关;
4. 本站文章均是网友提供,不完全保证技术分享内容的完整性、准确性、时效性、风险性和版权归属;如您发现该文章侵犯了您的权益,可联系我们第一时间进行删除;
5. 本站为非盈利性的个人网站,所有内容不会用来进行牟利,也不会利用任何形式的广告来间接获益,纯粹是为了广大技术爱好者提供技术内容和技术思想的分享性交流网站。

专注分享技术,共同学习,共同进步。侵权联系[81616952@qq.com]

Copyright (C)ICode9.com, All Rights Reserved.

ICode9版权所有