ICode9

精准搜索请尝试: 精确搜索
首页 > 其他分享> 文章详细

穷竭搜索AOJ Exhaustive Search

2021-11-17 13:00:57  阅读:151  来源: 互联网

标签:given elements return int 穷竭 AOJ element solve Exhaustive


原题链接

Write a program which reads a sequence A of n elements and an integer M, and outputs "yes" if you can make M by adding elements in A, otherwise "no". You can use an element only once.

You are given the sequence A and q questions where each question contains Mi.

Input

In the first line n is given. In the second line, n integers are given. In the third line q is given. Then, in the fourth line, q integers (Mi) are given.

Output

For each question Mi, print yes or no.

Constraints

  • n ≤ 20

  • q ≤ 200

  • 1 ≤ elements in A ≤ 2000

  • 1 ≤ Mi ≤ 2000

Sample Input 1

5
1 5 7 10 21
8
2 4 17 8 22 21 100 35

Sample Output 1

no
no
yes
yes
yes
yes
no
no

Notes

You can solve this problem by a Burte Force approach. Suppose solve(p, t) is a function which checkes whether you can make t by selecting elements after p-th element (inclusive). Then you can recursively call the following functions:

solve(0, M) solve(1, M-{sum created from elements before 1st element}) solve(2, M-{sum created from elements before 2nd element}) ...

The recursive function has two choices: you selected p-th element and not. So, you can check solve(p+1, t-A[p]) and solve(p+1, t) in solve(p, t) to check the all combinations.

For example, the following figure shows that 8 can be made by A[0] + A[2].

img

 

 

一种时间复杂度是O(2n)的究极暴力搜索算法

做法:判断每个元素是否可取,每次都有2种取法。

用递归的方式来解决(从m中加上w[i],用m是否等于M来判断是否这个数能用和来表示):

bool f;
void solve(int i,int m){ if(m == M){f = 1;return ;} if(i == n)return ; solve(i + 1,m) ; solve(i + 1,m + w[i]); return ; }

每次递归都有不选这个数(m)和选择这个数(m + w[i])两种选择,用f来标记是否可以用和来表示。

 

AC代码:

#include<bits/stdc++.h>

using namespace std;

const int N = 1e6 + 10;

int w[N];
int n,k,M;
bool f;
void solve(int i,int m){
    if(m == M){f = 1;return ;}
    if(i == n)return ;
    solve(i + 1,m) ;
    solve(i + 1,m + w[i]);
    return ;
}

int main(){
    scanf("%d",&n);
    for(int i = 0;i < n;i ++)scanf("%d",&w[i]);

    scanf("%d",&k);

    for(int i = 0;i < k;i ++){
        scanf("%d",&M);
        f = 0;
        solve(0,0);
        cout << (f?"yes" : "no") << endl;
    }

    return 0;
}

 

等学了DP再来补一个DP的做法。

标签:given,elements,return,int,穷竭,AOJ,element,solve,Exhaustive
来源: https://www.cnblogs.com/Moniq/p/15566736.html

本站声明: 1. iCode9 技术分享网(下文简称本站)提供的所有内容,仅供技术学习、探讨和分享;
2. 关于本站的所有留言、评论、转载及引用,纯属内容发起人的个人观点,与本站观点和立场无关;
3. 关于本站的所有言论和文字,纯属内容发起人的个人观点,与本站观点和立场无关;
4. 本站文章均是网友提供,不完全保证技术分享内容的完整性、准确性、时效性、风险性和版权归属;如您发现该文章侵犯了您的权益,可联系我们第一时间进行删除;
5. 本站为非盈利性的个人网站,所有内容不会用来进行牟利,也不会利用任何形式的广告来间接获益,纯粹是为了广大技术爱好者提供技术内容和技术思想的分享性交流网站。

专注分享技术,共同学习,共同进步。侵权联系[81616952@qq.com]

Copyright (C)ICode9.com, All Rights Reserved.

ICode9版权所有