ICode9

精准搜索请尝试: 精确搜索
首页 > 其他分享> 文章详细

1012 The Best Rank (25 分)(排序)

2021-11-06 18:32:52  阅读:177  来源: 互联网

标签:25 rank int Rank best student 91 id Best


To evaluate the performance of our first year CS majored students, we consider their grades of three courses only: C - C Programming Language, M - Mathematics (Calculus or Linear Algebra), and E - English. At the mean time, we encourage students by emphasizing on their best ranks -- that is, among the four ranks with respect to the three courses and the average grade, we print the best rank for each student.

For example, The grades of C, M, E and A - Average of 4 students are given as the following:

StudentID C M E A
310101 98 85 88 90
310102 70 95 88 84
310103 82 87 94 88
310104 91 91 91 91

Then the best ranks for all the students are No.1 since the 1st one has done the best in C Programming Language, while the 2nd one in Mathematics, the 3rd one in English, and the last one in average.

Input

Each input file contains one test case. Each case starts with a line containing 2 numbers N and M (<=2000), which are the total number of students, and the number of students who would check their ranks, respectively. Then N lines follow, each contains a student ID which is a string of 6 digits, followed by the three integer grades (in the range of [0, 100]) of that student in the order of C, M and E. Then there are M lines, each containing a student ID.

Output

For each of the M students, print in one line the best rank for him/her, and the symbol of the corresponding rank, separated by a space.

The priorities of the ranking methods are ordered as A > C > M > E. Hence if there are two or more ways for a student to obtain the same best rank, output the one with the highest priority.

If a student is not on the grading list, simply output "N/A".

Sample Input

5 6
310101 98 85 88
310102 70 95 88
310103 82 87 94
310104 91 91 91
310105 85 90 90
310101
310102
310103
310104
310105
999999

Sample Output

1 C
1 M
1 E
1 A
3 A
N/A

生词

英文 解释
Calculus 微积分
Linear Algebra 线性代数
emphasize on 关注,注重,强调
with respect to 关于

题目大意:

现已知n个考生的3门分数,平均分可以按照这三门算出来。然后分别对这四个分数从高到低排序,这样对每个考生来说有4个排名。k个查询,对于每一个学生id,输出当前id学生的最好的排名和它对应的分数,如果名次相同,按照A>C>M>E的顺序输出。如果当前id不存在,输出N/A

分析:

1、用结构体存储学生的id、四门成绩、四门排名、最好的排名的对应的科目下标
2、排名并列应该1、1、3、4、5,而不是1、1、2、3、4,否则会有一个测试点不过
3、平均分是四舍五入的,所以需要按照+0.5后取整,保证是四舍五入的(听说不四舍五入也能通过...)
4、存储的时候就按照ACME的顺序存储可以简化程序逻辑
5、用exist数组保存当前id是否存在,这个id对应的stu结构体的下标是多少。用i+1可以保证为0的都是不存在的可以直接输出N/A,其余不为0的保存的值是对应的结构体index + 1的值

原文链接:https://blog.csdn.net/liuchuo/article/details/52202171

题解

StudentID C M E A
310101 98 85 88 90
310102 70 95 88 84
310103 82 87 94 88
310104 91 91 91 91
310105 85 90 90 88

rank数组(存储的时候就按照ACME的顺序存储可以简化程序逻辑)

id A C M E
1 2 1 5 4
2 5 5 1 4
3 3 4 4 1
4 1 2 2 2
5 3 3 3 3

自己写的时候把rank数组搞出来了,但是接下来不会处理了,,,
然后借鉴了柳神的思路————把每一个id的rank数组最小的值的下标存到结点下的best属性里,然后就可以对应输出该坐标下的rank值以及ACME的字符~

这种保留下标的做法碰到过好几次了
下次再遇到一定要记得使用~

#include <bits/stdc++.h>

using namespace std;
struct student
{
    int id,c,m,e,a,best;
    vector<int> rank;
    //map<char,int> rank;
};
bool cmp1(student x,student y)
{
    return x.c>y.c;
}
bool cmp2(student x,student y)
{
    return x.m>y.m;
}
bool cmp3(student x,student y)
{
    return x.e>y.e;
}
bool cmp4(student x,student y)
{
    return x.a>y.a;
}
int exist[1000000];
int main()
{
#ifdef ONLINE_JUDGE
#else
    freopen("1.txt", "r", stdin);
#endif
    int N,M;
    cin>>N>>M;
    vector<student> v(N);
    for(int i=0;i<N;i++){
        cin>>v[i].id>>v[i].c>>v[i].m>>v[i].e;
        v[i].a=round((v[i].c+v[i].m+v[i].e)/3.0);
    }
    sort(v.begin(),v.end(),cmp4);
    int rk=0,pre=-1,in;
    for(int i=0;i<N;i++){
        if(v[i].a!=pre) rk=i+1;
        pre=v[i].a;
        //cout<<v[i].id<<" "<<v[i].a<<" "<<rk<<endl;
        v[i].rank.push_back(rk);
        //v[i].rank.insert(pair<int,char>(rk,'A'));
    }
    sort(v.begin(),v.end(),cmp1);
    rk=0,pre=-1;
    for(int i=0;i<N;i++){
        if(v[i].c!=pre) rk=i+1;
        pre=v[i].c;
        //cout<<v[i].id<<" "<<v[i].c<<" "<<rk<<endl;
        v[i].rank.push_back(rk);
        //v[i].rank.insert(pair<int,char>(rk,'C'));
    }
    sort(v.begin(),v.end(),cmp2);
    rk=0,pre=-1;
    for(int i=0;i<N;i++){
        if(v[i].m!=pre) rk=i+1;
        pre=v[i].m;
        //cout<<v[i].id<<" "<<v[i].m<<" "<<rk<<endl;
        v[i].rank.push_back(rk);
        //v[i].rank.insert(pair<int,char>(rk,'M'));
    }
    sort(v.begin(),v.end(),cmp3);
    rk=0,pre=-1;
    for(int i=0;i<N;i++){
        if(v[i].e!=pre) rk=i+1;
        pre=v[i].e;
        //cout<<v[i].id<<" "<<v[i].e<<" "<<rk<<endl;
        v[i].rank.push_back(rk);
        //v[i].rank.insert(pair<int,char>(rk,'E'));
    }
    for(int i=0;i<N;i++){
        exist[v[i].id]=i+1;
        v[i].best=0;
        int min=v[i].rank[0];
        for(int j=1;j<=3;j++){
            if(v[i].rank[j]<min){
                min=v[i].rank[j];
                v[i].best=j;
            }
        }

    }
    char c[5]={'A','C','M','E'};
    for(int i=0;i<M;i++){
        cin>>in;
        int temp=exist[in];
        if(temp){
            int best=v[temp-1].best;
            cout<<v[temp-1].rank[best]<<" "<<c[best]<<endl;
        }else cout<<"N/A"<<endl;
    }
    return 0;
}

柳神题解

#include <cstdio>
#include <algorithm>
using namespace std;
struct node {
    int id, best;
    int score[4], rank[4];
}stu[2005];
int exist[1000000], flag = -1;
bool cmp1(node a, node b) {return a.score[flag] > b.score[flag];}
int main() {
    int n, m, id;
    scanf("%d %d", &n, &m);
    for(int i = 0; i < n; i++) {
        scanf("%d %d %d %d", &stu[i].id, &stu[i].score[1], &stu[i].score[2], &stu[i].score[3]);
        stu[i].score[0] = (stu[i].score[1] + stu[i].score[2] + stu[i].score[3]) / 3.0 + 0.5;
    }
    for(flag = 0; flag <= 3; flag++) {
        sort(stu, stu + n, cmp1);
        stu[0].rank[flag] = 1;
        for(int i = 1; i < n; i++) {
            stu[i].rank[flag] = i + 1;
            if(stu[i].score[flag] == stu[i-1].score[flag])
                stu[i].rank[flag] = stu[i-1].rank[flag];
        }
    }
    for(int i = 0; i < n; i++) {
        exist[stu[i].id] = i + 1;
        stu[i].best = 0;
        int minn = stu[i].rank[0];
        for(int j = 1; j <= 3; j++) {
            if(stu[i].rank[j] < minn) {
                minn = stu[i].rank[j];
                stu[i].best = j;
            }
        }
    }
    char c[5] = {'A', 'C', 'M', 'E'};
    for(int i = 0; i < m; i++) {
        scanf("%d", &id);
        int temp = exist[id];
        if(temp) {
            int best = stu[temp-1].best;
            printf("%d %c\n", stu[temp-1].rank[best], c[best]);
        } else {
            printf("N/A\n");
        }
    }
    return 0;
}

标签:25,rank,int,Rank,best,student,91,id,Best
来源: https://www.cnblogs.com/moonlight1999/p/15517937.html

本站声明: 1. iCode9 技术分享网(下文简称本站)提供的所有内容,仅供技术学习、探讨和分享;
2. 关于本站的所有留言、评论、转载及引用,纯属内容发起人的个人观点,与本站观点和立场无关;
3. 关于本站的所有言论和文字,纯属内容发起人的个人观点,与本站观点和立场无关;
4. 本站文章均是网友提供,不完全保证技术分享内容的完整性、准确性、时效性、风险性和版权归属;如您发现该文章侵犯了您的权益,可联系我们第一时间进行删除;
5. 本站为非盈利性的个人网站,所有内容不会用来进行牟利,也不会利用任何形式的广告来间接获益,纯粹是为了广大技术爱好者提供技术内容和技术思想的分享性交流网站。

专注分享技术,共同学习,共同进步。侵权联系[81616952@qq.com]

Copyright (C)ICode9.com, All Rights Reserved.

ICode9版权所有