ICode9

精准搜索请尝试: 精确搜索
首页 > 其他分享> 文章详细

1047 Student List for Course (25 分)

2021-10-29 13:03:34  阅读:211  来源: 互联网

标签:25 1047 name courses scanf List number course BOB5


1. 题目

Zhejiang University has 40,000 students and provides 2,500 courses. Now given the registered course list of each student, you are supposed to output the student name lists of all the courses.

Input Specification:

Each input file contains one test case. For each case, the first line contains 2 numbers: N (≤40,000), the total number of students, and K (≤2,500), the total number of courses. Then N lines follow, each contains a student's name (3 capital English letters plus a one-digit number), a positive number C (≤20) which is the number of courses that this student has registered, and then followed by C course numbers. For the sake of simplicity, the courses are numbered from 1 to K.

Output Specification:

For each test case, print the student name lists of all the courses in increasing order of the course numbers. For each course, first print in one line the course number and the number of registered students, separated by a space. Then output the students' names in alphabetical order. Each name occupies a line.

Sample Input:

10 5
ZOE1 2 4 5
ANN0 3 5 2 1
BOB5 5 3 4 2 1 5
JOE4 1 2
JAY9 4 1 2 5 4
FRA8 3 4 2 5
DON2 2 4 5
AMY7 1 5
KAT3 3 5 4 2
LOR6 4 2 4 1 5

Sample Output:

1 4
ANN0
BOB5
JAY9
LOR6
2 7
ANN0
BOB5
FRA8
JAY9
JOE4
KAT3
LOR6
3 1
BOB5
4 7
BOB5
DON2
FRA8
JAY9
KAT3
LOR6
ZOE1
5 9
AMY7
ANN0
BOB5
DON2
FRA8
JAY9
KAT3
LOR6
ZOE1

2. 题意

该题与1039 Course List for Student (25 分)相反,通过给定的学生选课信息,得到每门课程的所有学生姓名并输出,学生姓名要按字母从小到大排序。

3. 思路——vector+排序

  1. 这里一开始想到用map,mep存储的速度没有数组存储快捷高效,在这题会导致超时甚至内存超限,主要是因为刚开始没有看到课程号是1~k的题目条件,有了这个条件,只要开一个k+1大小的数组,数组中的每一位即代表一门课程,数组的类型为vector,即用来存储该门课程的学生姓名。通过给定的学生选课信息,得到每门课程的所有学生姓名,再输出前需要对姓名进行排序后输出。

  2. 刚开始输入输出使用cin、cout,导致最后一个测试点一直是超时状态,无法通过。即使使用了ios::sync_with_stdio(false);取消同步也无济于事。后面就该用scanf、printf来进行输入输出,最后一个样例就可以通过了。总结:在有大量输入输出的情况下,还是直接使用scanf、printf为上策!

4. 代码

#include <iostream>
#include <vector>
#include <map>
#include <string>
#include <algorithm>

using namespace std;

// 使用scanf,printf的高效性
// 试过使用ios::sync_with_stdio(false);来取消同步,但是还是会超时
// 所以遇到多次输入输出,尽量还是使用scanf和printf 
int main()
{
	int n, k;
	scanf("%d%d", &n, &k);
	// 题目中有个条件是,输入的课程号为1~k ,所以这里设置数组大小为k+1即可 
	vector<string> course_name[k + 1];
	string name;
	int num, x;
	// 将选每门课程学生加入到vector中 
	while (n--)
	{
		cin >> name >> num;
		for (int i = 0; i < num; ++i)
		{
			scanf("%d", &x);
			course_name[x].push_back(name);
		}
	}
	for (int i = 1; i <= k; ++i)
	{
		printf("%d %d\n", i, course_name[i].size());
		// 输出的学生名字需要按字母排序 
		sort(course_name[i].begin(), course_name[i].end());
		for (int j = 0; j < course_name[i].size(); ++j)
			printf("%s\n", course_name[i][j].c_str());
	}
	return 0;
} 

标签:25,1047,name,courses,scanf,List,number,course,BOB5
来源: https://www.cnblogs.com/vanishzeng/p/15479925.html

本站声明: 1. iCode9 技术分享网(下文简称本站)提供的所有内容,仅供技术学习、探讨和分享;
2. 关于本站的所有留言、评论、转载及引用,纯属内容发起人的个人观点,与本站观点和立场无关;
3. 关于本站的所有言论和文字,纯属内容发起人的个人观点,与本站观点和立场无关;
4. 本站文章均是网友提供,不完全保证技术分享内容的完整性、准确性、时效性、风险性和版权归属;如您发现该文章侵犯了您的权益,可联系我们第一时间进行删除;
5. 本站为非盈利性的个人网站,所有内容不会用来进行牟利,也不会利用任何形式的广告来间接获益,纯粹是为了广大技术爱好者提供技术内容和技术思想的分享性交流网站。

专注分享技术,共同学习,共同进步。侵权联系[81616952@qq.com]

Copyright (C)ICode9.com, All Rights Reserved.

ICode9版权所有