ICode9

精准搜索请尝试: 精确搜索
首页 > 其他分享> 文章详细

PAT 甲级 1110 Complete Binary Tree

2019-02-17 15:47:29  阅读:285  来源: 互联网

标签:node Binary PAT Complete int s1 tree st step


https://pintia.cn/problem-sets/994805342720868352/problems/994805359372255232

 

Given a tree, you are supposed to tell if it is a complete binary tree.

Input Specification:

Each input file contains one test case. For each case, the first line gives a positive integer N (≤) which is the total number of nodes in the tree -- and hence the nodes are numbered from 0 to N−1. Then N lines follow, each corresponds to a node, and gives the indices of the left and right children of the node. If the child does not exist, a - will be put at the position. Any pair of children are separated by a space.

Output Specification:

For each case, print in one line YES and the index of the last node if the tree is a complete binary tree, or NO and the index of the root if not. There must be exactly one space separating the word and the number.

Sample Input 1:

9
7 8
- -
- -
- -
0 1
2 3
4 5
- -
- -

Sample Output 1:

YES 8

Sample Input 2:

8
- -
4 5
0 6
- -
2 3
- 7
- -
- -

Sample Output 2:

NO 1

代码:

#include <bits/stdc++.h>
using namespace std;

int N;
int vis[110];
int ans = -1, temp;

struct Node{
    int l;
    int r;
}node[110];

int StringtoInt(string s) {
    int len = s.length();
    int sum = 0;
    for(int i = 0; i < len; i ++) {
        sum = sum * 10 + (s[i] - '0');
    }
    return sum;
}

void dfs(int st, int step) {
    if(step > ans) {
        ans = step;
        temp = st;
    }

    if(node[st].l != -1) dfs(node[st].l, step * 2);
    if(node[st].r != -1) dfs(node[st].r, step * 2 + 1);
}

int main() {
    scanf("%d", &N);
    memset(vis, 0, sizeof(vis));
    for(int i = 0; i < N; i ++) {
        string s1, s2;
        cin >> s1 >> s2;
        if(s1 == "-") {
            node[i].l = -1;
        } else if(s1 != "-"){
            node[i].l = StringtoInt(s1);
            //cout << node[i].l << endl;
            vis[node[i].l] = 1;
        }

        if(s2 == "-") {
            node[i].r = -1;
        } else if(s2 != "-") {
            node[i].r = StringtoInt(s2);
            vis[node[i].r] = 1;
            //cout << node[i].r << endl;
        }
    }

    int root = 0;
    while(vis[root]) root ++;
    dfs(root, 1);

    if(ans == N)
        printf("YES %d\n", temp);
    else printf("NO %d\n", root);
    return 0;
}

  判断是不是完全二叉树要判断这个树是不是满的 看是不是最大的节点数等于一共的节点数目 dfs 求最大的节点下标

FH

标签:node,Binary,PAT,Complete,int,s1,tree,st,step
来源: https://www.cnblogs.com/zlrrrr/p/10391420.html

本站声明: 1. iCode9 技术分享网(下文简称本站)提供的所有内容,仅供技术学习、探讨和分享;
2. 关于本站的所有留言、评论、转载及引用,纯属内容发起人的个人观点,与本站观点和立场无关;
3. 关于本站的所有言论和文字,纯属内容发起人的个人观点,与本站观点和立场无关;
4. 本站文章均是网友提供,不完全保证技术分享内容的完整性、准确性、时效性、风险性和版权归属;如您发现该文章侵犯了您的权益,可联系我们第一时间进行删除;
5. 本站为非盈利性的个人网站,所有内容不会用来进行牟利,也不会利用任何形式的广告来间接获益,纯粹是为了广大技术爱好者提供技术内容和技术思想的分享性交流网站。

专注分享技术,共同学习,共同进步。侵权联系[81616952@qq.com]

Copyright (C)ICode9.com, All Rights Reserved.

ICode9版权所有