ICode9

精准搜索请尝试: 精确搜索
首页 > 其他分享> 文章详细

A - Monthly Expense

2021-10-01 21:31:41  阅读:178  来源: 互联网

标签:Monthly sum Farmer int 400 100 Expense 500


Farmer John is an astounding accounting wizard and has realized he might run out of money to run the farm. He has already calculated and recorded the exact amount of money (1 ≤ moneyi ≤ 10,000) that he will need to spend each day over the next N (1 ≤ N ≤ 100,000) days.

FJ wants to create a budget for a sequential set of exactly M (1 ≤ M ≤ N) fiscal periods called “fajomonths”. Each of these fajomonths contains a set of 1 or more consecutive days. Every day is contained in exactly one fajomonth.

FJ’s goal is to arrange the fajomonths so as to minimize the expenses of the fajomonth with the highest spending and thus determine his monthly spending limit.

Input
Line 1: Two space-separated integers: N and M
Lines 2…N+1: Line i+1 contains the number of dollars Farmer John spends on the ith day
Output
Line 1: The smallest possible monthly limit Farmer John can afford to live with.

Sample Input
7 5
100
400
300
100
500
101
400

Sample Output
500

Hint
If Farmer John schedules the months so that the first two days are a month, the third and fourth are a month, and the last three are their own months, he spends at most $500 in any month. Any other method of scheduling gives a larger minimum monthly limit.

题目大意:
给出n个数,将其分为至多m段,求和最大的一段值最少为多少,如例子
7 5
100
400
300
100
500
101
400

最优分法是{100,400}、{300,100}、{500}、{101}、{400}

和最大的集合的和为500

解题思路:
二分枚举答案,如例题,

  • 先求答案范围,l =100,r=100+400+300+100+500+101+400=1901;
    则范围为[100,1901}
  • 枚举答案m=(l+r)/2=1000
  • 遍历数组,判断sum+a[i]是否大于1000,大于1000后集合数+1,否则sum+=a[i]
  • 判断集合数是否>m,若大于m,则答案过小了,l = m+1,否则概述恰好是答案,或则过大了,令r=m
  • 一直二分逐渐缩小答案区间,当r<=l时,l就是答案

完整代码:

#include<iostream>
using namespace std;
int main() {
	int n,n2;
	int a[100010];
	cin>>n>>n2;
	int sum=0;
	int ma=0;
	for(int i=0;i<n;i++){
		cin>>a[i];
		sum+=a[i];			//最大范围 
		ma=max(ma,a[i]);	//最小范围 
	}
	int l=ma,r=sum,m;
	while(r>l){	//二分 
		m=(l+r)/2;
		int j=1;
		sum=0;
		for(int i=0;i<n;i++){
			
			if(sum+a[i]<=m){
				sum+=a[i];
			}else{
				sum=a[i];
				j++;
			}
		}
		if(j<=n2){
			r=m;
		}else{
			l=m+1;
		}
	}
	cout<<l;
}

标签:Monthly,sum,Farmer,int,400,100,Expense,500
来源: https://blog.csdn.net/weixin_52115456/article/details/120580899

本站声明: 1. iCode9 技术分享网(下文简称本站)提供的所有内容,仅供技术学习、探讨和分享;
2. 关于本站的所有留言、评论、转载及引用,纯属内容发起人的个人观点,与本站观点和立场无关;
3. 关于本站的所有言论和文字,纯属内容发起人的个人观点,与本站观点和立场无关;
4. 本站文章均是网友提供,不完全保证技术分享内容的完整性、准确性、时效性、风险性和版权归属;如您发现该文章侵犯了您的权益,可联系我们第一时间进行删除;
5. 本站为非盈利性的个人网站,所有内容不会用来进行牟利,也不会利用任何形式的广告来间接获益,纯粹是为了广大技术爱好者提供技术内容和技术思想的分享性交流网站。

专注分享技术,共同学习,共同进步。侵权联系[81616952@qq.com]

Copyright (C)ICode9.com, All Rights Reserved.

ICode9版权所有