ICode9

精准搜索请尝试: 精确搜索
首页 > 其他分享> 文章详细

PTA B1016 Phone Bills 模拟题

2021-10-01 20:58:37  阅读:125  来源: 互联网

标签:01 off temp 模拟题 15 time B1016 line Bills


B1016 Phone Bills

A long-distance telephone company charges its customers by the following rules:

Making a long-distance call costs a certain amount per minute, depending on the time of day when the call is made. When a customer starts connecting a long-distance call, the time will be recorded, and so will be the time when the customer hangs up the phone. Every calendar month, a bill is sent to the customer for each minute called (at a rate determined by the time of day). Your job is to prepare the bills for each month, given a set of phone call records.

Input Specification:
Each input file contains one test case. Each case has two parts: the rate structure, and the phone call records.

The rate structure consists of a line with 24 non-negative integers denoting the toll (cents/minute) from 00:00 - 01:00, the toll from 01:00 - 02:00, and so on for each hour in the day.

The next line contains a positive number N (≤1000), followed by N lines of records. Each phone call record consists of the name of the customer (string of up to 20 characters without space), the time and date (MM:dd:HH:mm), and the word on-line or off-line.

For each test case, all dates will be within a single month. Each on-line record is paired with the chronologically next record for the same customer provided it is an off-line record. Any on-line records that are not paired with an off-line record are ignored, as are off-line records not paired with an on-line record. It is guaranteed that at least one call is well paired in the input. You may assume that no two records for the same customer have the same time. Times are recorded using a 24-hour clock.

Output Specification:
For each test case, you must print a phone bill for each customer.

Bills must be printed in alphabetical order of customers’ names. For each customer, first print in a line the name of the customer and the month of the bill in the format shown by the sample. Then for each time period of a call, print in one line the beginning and ending time and date (dd:HH:mm), the lasting time (in minute) and the charge of the call. The calls must be listed in chronological order. Finally, print the total charge for the month in the format shown by the sample.

Sample Input:
10 10 10 10 10 10 20 20 20 15 15 15 15 15 15 15 20 30 20 15 15 10 10 10
10
CYLL 01:01:06:01 on-line
CYLL 01:28:16:05 off-line
CYJJ 01:01:07:00 off-line
CYLL 01:01:08:03 off-line
CYJJ 01:01:05:59 on-line
aaa 01:01:01:03 on-line
aaa 01:02:00:01 on-line
CYLL 01:28:15:41 on-line
aaa 01:05:02:24 on-line
aaa 01:04:23:59 off-line
结尾无空行
Sample Output:
CYJJ 01
01:05:59 01:07:00 61 $12.10
Total amount: $12.10
CYLL 01
01:06:01 01:08:03 122 $24.40
28:15:41 28:16:05 24 $3.85
Total amount: $28.25
aaa 01
02:00:01 04:23:59 4318 $638.80
Total amount: $638.80
记录点:

  1. cmp函数的编写
bool cmp(stu a1,stu b){
	int i=strcmp(a1.name,b.name);
	if(i!=0) return i<0;//优先按照姓名字典顺序从小到大排序 
	else if (a1.MM!=b.MM) return a1.MM<b.MM;
	else if(a1.dd!=b.dd) return a1.dd<b.dd;
}
  1. on-lineoff-line的寻找配对
  2. 同一用户和下一个用户
#include<bits/stdc++.h>
using namespace std;
int a[24];
struct stu{
	char name[20];
	int MM,dd,HH,mm;
	char onoff[20];
}s[1000],temp;
bool cmp(stu a1,stu b){
	int i=strcmp(a1.name,b.name);
	if(i!=0) return i<0;//优先按照姓名字典顺序从小到大排序 
	else if (a1.MM!=b.MM) return a1.MM<b.MM;
	else if(a1.dd!=b.dd) return a1.dd<b.dd;
	else if(a1.HH!=b.HH) return a1.HH<b.HH;
	else if(a1.mm!=b.mm) return a1.mm<b.mm;
	
}
void get_ans(int on,int off,int &time,int &money){
	temp=s[on];
	while(temp.dd<s[off].dd||temp.HH<s[off].HH||temp.mm<s[off].mm){
		time++;
		money+=a[temp.HH];
		temp.mm++;
		if(temp.mm>=60){
			temp.mm=0;
			temp.HH++;
		}
		if(temp.HH>=24){
			temp.HH=0;
			temp.dd++;
		}
	}
}
int main(){
	int n,i;
	for(int i=0;i<24;i++){
		scanf("%d",&a[i]);
	} 
	scanf("%d",&n);
	for(i=0;i<n;i++){
		scanf("%s%d:%d:%d:%d%s",s[i].name,&s[i].MM,&s[i].dd,&s[i].HH,&s[i].mm,s[i].onoff);
	}
	sort(s,s+n,cmp);
	int on=0,off,next;
	while(on<n){
		int needPrint=0;
		next=on;
		while(next<n&&strcmp(s[next].name,s[on].name)==0){//同一个用户 
			if(needPrint==0&&strcmp(s[next].onoff,"on-line")==0) 
				needPrint=1;//找到on
			else if(needPrint==1&&strcmp(s[next].onoff,"off-line")==0) 
				needPrint=2;
			next++;			 
		}
		if(needPrint<2){
			//没有找到对应的on-off
			on=next;continue; 
		}
		int Allmoney=0;
		printf("%s %02d\n",s[on].name,s[on].MM);
		while(on<next){//寻找该用户的所有配对 
			while(on<next-1&&!(strcmp(s[on].onoff,"on-line")==0&&strcmp(s[on+1].onoff,"off-line")==0)) {
				on++;//直到找到连续的on-line and off 
			}
			off=on+1;
			if(off==next){
				on=next;
				break;
			}
			printf("%02d:%02d:%02d ",s[on].dd,s[on].HH,s[on].mm);
			printf("%02d:%02d:%02d ",s[off].dd,s[off].HH,s[off].mm);
			int time=0,money=0;
			get_ans(on,off,time,money);
			Allmoney+=money;
			printf("%d $%.2f\n",time,money/100.0);
			on=off+1;
		}
		printf("Total amount: $%.2f\n",Allmoney/100.0);
	}
    return 0;
}

标签:01,off,temp,模拟题,15,time,B1016,line,Bills
来源: https://blog.csdn.net/juli_eyre/article/details/120580753

本站声明: 1. iCode9 技术分享网(下文简称本站)提供的所有内容,仅供技术学习、探讨和分享;
2. 关于本站的所有留言、评论、转载及引用,纯属内容发起人的个人观点,与本站观点和立场无关;
3. 关于本站的所有言论和文字,纯属内容发起人的个人观点,与本站观点和立场无关;
4. 本站文章均是网友提供,不完全保证技术分享内容的完整性、准确性、时效性、风险性和版权归属;如您发现该文章侵犯了您的权益,可联系我们第一时间进行删除;
5. 本站为非盈利性的个人网站,所有内容不会用来进行牟利,也不会利用任何形式的广告来间接获益,纯粹是为了广大技术爱好者提供技术内容和技术思想的分享性交流网站。

专注分享技术,共同学习,共同进步。侵权联系[81616952@qq.com]

Copyright (C)ICode9.com, All Rights Reserved.

ICode9版权所有