ICode9

精准搜索请尝试: 精确搜索
首页 > 其他分享> 文章详细

1031 Hello World for U (20 分)

2021-09-17 21:00:03  阅读:185  来源: 互联网

标签:20 string int contains characters World line 1031 n2


Given any string of N (≥5) characters, you are asked to form the characters into the shape of U. For example, helloworld can be printed as:

h  d
e  l
l  r
lowo

That is, the characters must be printed in the original order, starting top-down from the left vertical line with n1​ characters, then left to right along the bottom line with n2​ characters, and finally bottom-up along the vertical line with n3​ characters. And more, we would like U to be as squared as possible -- that is, it must be satisfied that n1​=n3​=max { k | k≤n2​ for all 3≤n2​≤N } with n1​+n2​+n3​−2=N.

Input Specification:

Each input file contains one test case. Each case contains one string with no less than 5 and no more than 80 characters in a line. The string contains no white space.

Output Specification:

For each test case, print the input string in the shape of U as specified in the description.

Sample Input:

helloworld!

结尾无空行

Sample Output:

h   !
e   d
l   l
lowor

结尾无空行

#include<iostream>
#include<cstring>
using namespace std;
int main()
{
    string a;
    cin>>a;
    int len=a.length()+2;
    int b=len/3;    //竖着的长度
    int i,j;
    j=len%3+b;      //最底下一层的长度
    int kong=j-2;
    for(i=0;i<b-1;i++)      //输出前b-1行的内容
    {
        cout<<a[i];
        for(int o=0;o<kong;o++){
            cout<<" ";
        }
        cout<<a[len-3-i]<<endl;
    }
    //输出最后一行
    for( i=b-1;i<=b+kong;i++)
    {
        cout<<a[i];
    }
}

标签:20,string,int,contains,characters,World,line,1031,n2
来源: https://blog.csdn.net/qq_52245648/article/details/120356647

本站声明: 1. iCode9 技术分享网(下文简称本站)提供的所有内容,仅供技术学习、探讨和分享;
2. 关于本站的所有留言、评论、转载及引用,纯属内容发起人的个人观点,与本站观点和立场无关;
3. 关于本站的所有言论和文字,纯属内容发起人的个人观点,与本站观点和立场无关;
4. 本站文章均是网友提供,不完全保证技术分享内容的完整性、准确性、时效性、风险性和版权归属;如您发现该文章侵犯了您的权益,可联系我们第一时间进行删除;
5. 本站为非盈利性的个人网站,所有内容不会用来进行牟利,也不会利用任何形式的广告来间接获益,纯粹是为了广大技术爱好者提供技术内容和技术思想的分享性交流网站。

专注分享技术,共同学习,共同进步。侵权联系[81616952@qq.com]

Copyright (C)ICode9.com, All Rights Reserved.

ICode9版权所有