ICode9

精准搜索请尝试: 精确搜索
首页 > 其他分享> 文章详细

1047 Student List for Course (25 分)

2021-09-13 23:35:00  阅读:171  来源: 互联网

标签:25 1047 name int List number courses 课程 BOB5


Zhejiang University has 40,000 students and provides 2,500 courses. Now given the registered course list of each student, you are supposed to output the student name lists of all the courses.

Input Specification:

Each input file contains one test case. For each case, the first line contains 2 numbers: N (≤40,000), the total number of students, and K (≤2,500), the total number of courses. Then N lines follow, each contains a student’s name (3 capital English letters plus a one-digit number), a positive number C (≤20) which is the number of courses that this student has registered, and then followed by C course numbers. For the sake of simplicity, the courses are numbered from 1 to K.

Output Specification:

For each test case, print the student name lists of all the courses in increasing order of the course numbers. For each course, first print in one line the course number and the number of registered students, separated by a space. Then output the students’ names in alphabetical order. Each name occupies a line.

Sample Input:

10 5
ZOE1 2 4 5
ANN0 3 5 2 1
BOB5 5 3 4 2 1 5
JOE4 1 2
JAY9 4 1 2 5 4
FRA8 3 4 2 5
DON2 2 4 5
AMY7 1 5
KAT3 3 5 4 2
LOR6 4 2 4 1 5

Sample Output:

1 4
ANN0
BOB5
JAY9
LOR6
2 7
ANN0
BOB5
FRA8
JAY9
JOE4
KAT3
LOR6
3 1
BOB5
4 7
BOB5
DON2
FRA8
JAY9
KAT3
LOR6
ZOE1
5 9
AMY7
ANN0
BOB5
DON2
FRA8
JAY9
KAT3
LOR6
ZOE1

解释:

输入学生总数N,在输入课程总数K

接下来N行输入每个学生的选课信息包括,学生姓名,课程总数,各个课程编号

输出:

按课程编程从1-K输出

先输出课程编号,然后是课程人数

接下数额该课程的学生名称,按照字典升序

#include<stdio.h>
#include<vector>
#include<string.h>
#include<iostream>
#include<algorithm>
const int Max=2510;
using namespace std;
char name[41000][5];    //存放学生姓名
vector <int> Class[Max];//Class[i]存放第门课所有学生姓名在数组中的编号
bool cmp(int a,int b){
    return strcmp(name[a],name[b])<0;//名字按字典序升序
}
int main()
{
    int N,M,k,courseid;
    //输入总学生数,和总课程数
    cin>>N>>M;
    for(int i=0;i<N;i++)
    {
        //输入学生姓名和课程数
        cin>>name[i]>>k;
        //输入课程编号
        for(int j=0;j<k;j++){
            cin>>courseid;
            Class[courseid].push_back(i);
        }
    }
	//输出结果
    for(int i=1;i<=M;i++)
    {
        //输出课程编号,课程人数
        cout<<i<<" "<<Class[i].size()<<endl;
        //名字排序完输出
        sort(Class[i].begin(),Class[i].end(),cmp);
        for(int j=0;j<Class[i].size();j++)
            printf("%s\n",name[Class[i][j]]);
    }
    return 0;
}

标签:25,1047,name,int,List,number,courses,课程,BOB5
来源: https://blog.csdn.net/naexting/article/details/120277876

本站声明: 1. iCode9 技术分享网(下文简称本站)提供的所有内容,仅供技术学习、探讨和分享;
2. 关于本站的所有留言、评论、转载及引用,纯属内容发起人的个人观点,与本站观点和立场无关;
3. 关于本站的所有言论和文字,纯属内容发起人的个人观点,与本站观点和立场无关;
4. 本站文章均是网友提供,不完全保证技术分享内容的完整性、准确性、时效性、风险性和版权归属;如您发现该文章侵犯了您的权益,可联系我们第一时间进行删除;
5. 本站为非盈利性的个人网站,所有内容不会用来进行牟利,也不会利用任何形式的广告来间接获益,纯粹是为了广大技术爱好者提供技术内容和技术思想的分享性交流网站。

专注分享技术,共同学习,共同进步。侵权联系[81616952@qq.com]

Copyright (C)ICode9.com, All Rights Reserved.

ICode9版权所有