ICode9

精准搜索请尝试: 精确搜索
首页 > 其他分享> 文章详细

PAT-A1058 A+B in Hogwarts (钱币转换)

2021-09-13 21:33:04  阅读:138  来源: 互联网

标签:PAT A1058 .% long 29 Sickle Hogwarts Galleon lld


A1058 A+B in Hogwarts (钱币转换)

If you are a fan of Harry Potter, you would know the world of magic has its own currency system – as Hagrid explained it to Harry, “Seventeen silver Sickles to a Galleon and twenty-nine Knuts to a Sickle, it’s easy enough.” Your job is to write a program to compute A+B where A and B are given in the standard form of Galleon.Sickle.Knut (Galleon is an integer in [0,107], Sickle is an integer in [0, 17), and Knut is an integer in [0, 29)).

Input Specification:

Each input file contains one test case which occupies a line with A and B in the standard form, separated by one space.

Output Specification:

For each test case you should output the sum of A and B in one line, with the same format as the input.

Sample Input:

3.2.1 10.16.27

结尾无空行

Sample Output:

14.1.28

题意:

输入两个Galleon.Sickle.Knut货币的值,将值相加,输出结果。

分析:

这道题说实话并不难,可我不愧为踩坑小能手,相信很多人这个题目没有拿到满分都是第二个测试点没有通过的吧,大家的问题应该是没有考虑到数值的溢出吧,所以把int改成long long 类型的就行了,但是我!哎,我是错在了c>=29和b>=17,我错在没有写这个等于号,题目中是不包含,改了之后成功AC!

易错点:数值溢出&数值范围

代码如下:

#include<cstdio>
int main(){
	long long a,b,c,d,e,f;//注意!
	scanf("%lld.%lld.%lld %lld.%lld.%lld",&a,&b,&c,&d,&e,&f);
	a+=d;
	b+=e;
	c+=f;
	if(c>=29){//注意!
		c%=29;
		b++;
	} 
	if(b>=17){
		b%=17;
		a++;
	}
	printf("%lld.%lld.%lld",a,b,c); 
	return 0;
}

标签:PAT,A1058,.%,long,29,Sickle,Hogwarts,Galleon,lld
来源: https://blog.csdn.net/weixin_46055626/article/details/120275921

本站声明: 1. iCode9 技术分享网(下文简称本站)提供的所有内容,仅供技术学习、探讨和分享;
2. 关于本站的所有留言、评论、转载及引用,纯属内容发起人的个人观点,与本站观点和立场无关;
3. 关于本站的所有言论和文字,纯属内容发起人的个人观点,与本站观点和立场无关;
4. 本站文章均是网友提供,不完全保证技术分享内容的完整性、准确性、时效性、风险性和版权归属;如您发现该文章侵犯了您的权益,可联系我们第一时间进行删除;
5. 本站为非盈利性的个人网站,所有内容不会用来进行牟利,也不会利用任何形式的广告来间接获益,纯粹是为了广大技术爱好者提供技术内容和技术思想的分享性交流网站。

专注分享技术,共同学习,共同进步。侵权联系[81616952@qq.com]

Copyright (C)ICode9.com, All Rights Reserved.

ICode9版权所有