ICode9

精准搜索请尝试: 精确搜索
首页 > 其他分享> 文章详细

OpenJudge Biorhythms

2021-09-05 21:05:37  阅读:217  来源: 互联网

标签:given Biorhythms days next peak triple OpenJudge occurs


目录

Biorhythms

要求:

描述: 

输入: 

输出: 

样例输入: 

样例输出: 

问题分析: 

最终代码:

总结: 


Biorhythms

要求:

总时间限制: 3000ms

内存限制: 65536kB

描述: 

Some people believe that there are three cycles in a person's life that start the day he or she is born. These three cycles are the physical, emotional, and intellectual cycles, and they have periods of lengths 23, 28, and 33 days, respectively. There is one peak in each period of a cycle. At the peak of a cycle, a person performs at his or her best in the corresponding field (physical, emotional or mental). For example, if it is the mental curve, thought processes will be sharper and concentration will be easier. 
Since the three cycles have different periods, the peaks of the three cycles generally occur at different times. We would like to determine when a triple peak occurs (the peaks of all three cycles occur in the same day) for any person. For each cycle, you will be given the number of days from the beginning of the current year at which one of its peaks (not necessarily the first) occurs. You will also be given a date expressed as the number of days from the beginning of the current year. You task is to determine the number of days from the given date to the next triple peak. The given date is not counted. For example, if the given date is 10 and the next triple peak occurs on day 12, the answer is 2, not 3. If a triple peak occurs on the given date, you should give the number of days to the next occurrence of a triple peak.

输入: 

You will be given a number of cases. The input for each case consists of one line of four integers p, e, i, and d. The values p, e, and i are the number of days from the beginning of the current year at which the physical, emotional, and intellectual cycles peak, respectively. The value d is the given date and may be smaller than any of p, e, or i. All values are non-negative and at most 365, and you may assume that a triple peak will occur within 21252 days of the given date. The end of input is indicated by a line in which p = e = i = d = -1.

输出: 

For each test case, print the case number followed by a message indicating the number of days to the next triple peak, in the form:

Case 1: the next triple peak occurs in 1234 days.

Use the plural form ``days'' even if the answer is 1.

样例输入: 

0 0 0 0
0 0 0 100
5 20 34 325
4 5 6 7
283 102 23 320
203 301 203 40
-1 -1 -1 -1

样例输出: 

Case 1: the next triple peak occurs in 21252 days.
Case 2: the next triple peak occurs in 21152 days.
Case 3: the next triple peak occurs in 19575 days.
Case 4: the next triple peak occurs in 16994 days.
Case 5: the next triple peak occurs in 8910 days.
Case 6: the next triple peak occurs in 10789 days.

问题分析: 

题目需要我们找到人的首个三个生理周期交汇处,也就是说这个时间刚好是三个生理周期的顶峰。而根据题意,体力周期、情感周期、智力周期的周期跨度分别是23天、28天、33天。而输入给我们的4个数代表:当前天已经是某个体力周期的p天后、某个情感周期的e天后、某个智力周期的i天后,且已经经过了d天。

这个题目的关键在于信息颇为繁杂,信息量大,所以一时间不一定能理清题目的含义。而抛开背景,这个题目的本质是一个同余问题(中国剩余定理),希望找到一个尽量小的正数x,使得x+d\equiv p(\text{mod} \ 23)\land x+d\equiv e(\text{mod}\ 28)\land x+d\equiv i(\text{mod} \ 33).

那么我们可以利用枚举的方式来求最终的答案,而为了节省时间,我们可以考虑每次循环增加33,而不是一个一个增加。

最终代码:

#include<iostream>
using namespace std;
int main(){
    int p,e,i,d;
    scanf("%d%d%d%d",&p,&e,&i,&d);
    int Case=0;
    while(p!=-1||e!=-1||i!=-1||d!=-1){
        Case++;
        int Peak=i%33;//不要只写i,因为i可能会很大,不是最小的余数
        while((Peak-p)%23!=0||(Peak-e)%28!=0){
            Peak+=33;
        }
        if(Peak-d<=0) Peak+=21252;
        printf("Case %d: the next triple peak occurs in %d days.\n",Case,Peak-d);
        scanf("%d%d%d%d",&p,&e,&i,&d);
    }
}

总结: 

这个题目本质不是很难,关键是理清题目中的各类信息,抓住题目的本质——同余,最后利用枚举的方式来解决同余问题即可。如果这篇文章对您有所帮助的话,请不要忘了点赞关注哦!

标签:given,Biorhythms,days,next,peak,triple,OpenJudge,occurs
来源: https://blog.csdn.net/qq_51767234/article/details/120120857

本站声明: 1. iCode9 技术分享网(下文简称本站)提供的所有内容,仅供技术学习、探讨和分享;
2. 关于本站的所有留言、评论、转载及引用,纯属内容发起人的个人观点,与本站观点和立场无关;
3. 关于本站的所有言论和文字,纯属内容发起人的个人观点,与本站观点和立场无关;
4. 本站文章均是网友提供,不完全保证技术分享内容的完整性、准确性、时效性、风险性和版权归属;如您发现该文章侵犯了您的权益,可联系我们第一时间进行删除;
5. 本站为非盈利性的个人网站,所有内容不会用来进行牟利,也不会利用任何形式的广告来间接获益,纯粹是为了广大技术爱好者提供技术内容和技术思想的分享性交流网站。

专注分享技术,共同学习,共同进步。侵权联系[81616952@qq.com]

Copyright (C)ICode9.com, All Rights Reserved.

ICode9版权所有