ICode9

精准搜索请尝试: 精确搜索
首页 > 其他分享> 文章详细

PAT (Advanced Level) 1045 Favorite Color Stripe(LCS,非降序)

2021-08-22 13:04:10  阅读:202  来源: 互联网

标签:PAT LCS 1045 int favorite colors her stripe String


1045 Favorite Color Stripe (30 分)  

Eva is trying to make her own color stripe out of a given one. She would like to keep only her favorite colors in her favorite order by cutting off those unwanted pieces and sewing the remaining parts together to form her favorite color stripe.

It is said that a normal human eye can distinguish about less than 200 different colors, so Eva's favorite colors are limited. However the original stripe could be very long, and Eva would like to have the remaining favorite stripe with the maximum length. So she needs your help to find her the best result.

Note that the solution might not be unique, but you only have to tell her the maximum length. For example, given a stripe of colors {2 2 4 1 5 5 6 3 1 1 5 6}. If Eva's favorite colors are given in her favorite order as {2 3 1 5 6}, then she has 4 possible best solutions {2 2 1 1 1 5 6}, {2 2 1 5 5 5 6}, {2 2 1 5 5 6 6}, and {2 2 3 1 1 5 6}.

Input Specification:

Each input file contains one test case. For each case, the first line contains a positive integer N (≤200) which is the total number of colors involved (and hence the colors are numbered from 1 to N). Then the next line starts with a positive integer M (≤200) followed by M Eva's favorite color numbers given in her favorite order. Finally the third line starts with a positive integer L (≤104) which is the length of the given stripe, followed by L colors on the stripe. All the numbers in a line a separated by a space.

Output Specification:

For each test case, simply print in a line the maximum length of Eva's favorite stripe.

Sample Input:

6
5 2 3 1 5 6
12 2 2 4 1 5 5 6 3 1 1 5 6
  结尾无空行

Sample Output:

7
  结尾无空行    
import java.io.BufferedReader;
import java.io.IOException;
import java.io.InputStreamReader;

public class Main {
    public static void main(String[] args) throws IOException {
        BufferedReader reader = new BufferedReader(new InputStreamReader(System.in));
        String s = reader.readLine();
        int N = Integer.parseInt(s);        //N种颜色
        String s1 = reader.readLine();
        String[] s2 = s1.split(" ");
        int M = Integer.parseInt(s2[0]);
        int[] favorite = new int[M];       //最喜欢的颜色序列
        for (int i = 0; i < M; i++) {
            favorite[i] = Integer.parseInt(s2[i + 1]);
        }

        String s3 = reader.readLine();
        String[] s4 = s3.split(" ");
        int L = Integer.parseInt(s4[0]);
        int[] gaven = new int[L];         //给定条纹
        for (int i = 0; i < L; i++) {
            gaven[i] = Integer.parseInt(s4[i + 1]);
        }

        System.out.println(maxLongCommonSubsquence(favorite, gaven, M, L));
    }

    public static int maxLongCommonSubsquence(int[] arr1, int[] arr2, int n1, int n2){
        int[][] dp = new int[n1 + 1][n2 + 1];

        for (int i = 1; i <= n1; i++) {
            for (int j = 1; j <= n2; j++){
                int max = Math.max(dp[i - 1][j], dp[i][j - 1]);
                if (arr1[i-1] == arr2[j-1]){
                    dp[i][j] = max + 1;
                }else {
                    dp[i][j] = max;
                }
            }
        }
        return dp[n1][n2];
    }
}

  

标签:PAT,LCS,1045,int,favorite,colors,her,stripe,String
来源: https://www.cnblogs.com/jasonXY/p/15171943.html

本站声明: 1. iCode9 技术分享网(下文简称本站)提供的所有内容,仅供技术学习、探讨和分享;
2. 关于本站的所有留言、评论、转载及引用,纯属内容发起人的个人观点,与本站观点和立场无关;
3. 关于本站的所有言论和文字,纯属内容发起人的个人观点,与本站观点和立场无关;
4. 本站文章均是网友提供,不完全保证技术分享内容的完整性、准确性、时效性、风险性和版权归属;如您发现该文章侵犯了您的权益,可联系我们第一时间进行删除;
5. 本站为非盈利性的个人网站,所有内容不会用来进行牟利,也不会利用任何形式的广告来间接获益,纯粹是为了广大技术爱好者提供技术内容和技术思想的分享性交流网站。

专注分享技术,共同学习,共同进步。侵权联系[81616952@qq.com]

Copyright (C)ICode9.com, All Rights Reserved.

ICode9版权所有