ICode9

精准搜索请尝试: 精确搜索
首页 > 其他分享> 文章详细

uva 10815,andy's first ditionary(set,stringstream的简单运用)

2019-02-06 12:38:15  阅读:348  来源: 互联网

标签:set temp int 单词 andy 10815 dict include


题意:输入一个文本,找出所有不同的单词,按字典序从小到大输出。单词不区分大小写。

样例输入:

Adventures in DisneylandTwo blondes were going to Disneyland when they came to a fork in theroad. The sign read: "Disneyland Left."So they went home.

 

样例输出:

a
adventures
blondes
came
disneyland
fork
going
home
in
left
read
road
sign
8O
the
they
to
two
went
were
when

代码如下:

#include<set>
#include<iostream>
#include<sstream>
#include<string>
#include<cstring>
using namespace std;
 int main(int argc, char const *argv[]) {
  string s,temp;
  set<string>dict;
  set<string>::iterator it;
  stringstream ss;
  while(cin>>s){
    for(int i=0;i<s.length();i++){
      if (isalpha(s[i])) {
        s[i]=tolower(s[i]);//字母变为小写
      }
      else s[i]=' ';//将所有标点符号变为空格
      
      
    }stringstream ss(s);
      while(ss>>temp){
        dict.insert(temp);//将转换后的单词输入set
      }
  }
  for(it=dict.begin();it!=dict.end();it++){
    std::cout << *it << '\n';//按字典序输出
  }
  return 0;
}

 



标签:set,temp,int,单词,andy,10815,dict,include
来源: https://www.cnblogs.com/azheng9929/p/10353607.html

本站声明: 1. iCode9 技术分享网(下文简称本站)提供的所有内容,仅供技术学习、探讨和分享;
2. 关于本站的所有留言、评论、转载及引用,纯属内容发起人的个人观点,与本站观点和立场无关;
3. 关于本站的所有言论和文字,纯属内容发起人的个人观点,与本站观点和立场无关;
4. 本站文章均是网友提供,不完全保证技术分享内容的完整性、准确性、时效性、风险性和版权归属;如您发现该文章侵犯了您的权益,可联系我们第一时间进行删除;
5. 本站为非盈利性的个人网站,所有内容不会用来进行牟利,也不会利用任何形式的广告来间接获益,纯粹是为了广大技术爱好者提供技术内容和技术思想的分享性交流网站。

专注分享技术,共同学习,共同进步。侵权联系[81616952@qq.com]

Copyright (C)ICode9.com, All Rights Reserved.

ICode9版权所有