ICode9

精准搜索请尝试: 精确搜索
首页 > 其他分享> 文章详细

FatMouse and Cheese --- 记忆化搜索

2021-07-31 11:01:30  阅读:147  来源: 互联网

标签:Cheese cheese int FatMouse --- location each dp


**

FatMouse and Cheese

**
题目:
FatMouse has stored some cheese in a city. The city can be considered as a square grid of dimension n: each grid location is labelled (p,q) where 0 <= p < n and 0 <= q < n. At each grid location Fatmouse has hid between 0 and 100 blocks of cheese in a hole. Now he’s going to enjoy his favorite food.

FatMouse begins by standing at location (0,0). He eats up the cheese where he stands and then runs either horizontally or vertically to another location. The problem is that there is a super Cat named Top Killer sitting near his hole, so each time he can run at most k locations to get into the hole before being caught by Top Killer. What is worse – after eating up the cheese at one location, FatMouse gets fatter. So in order to gain enough energy for his next run, he has to run to a location which have more blocks of cheese than those that were at the current hole.

Given n, k, and the number of blocks of cheese at each grid location, compute the maximum amount of cheese FatMouse can eat before being unable to move.

Input
There are several test cases. Each test case consists of

a line containing two integers between 1 and 100: n and k
n lines, each with n numbers: the first line contains the number of blocks of cheese at locations (0,0) (0,1) … (0,n-1); the next line contains the number of blocks of cheese at locations (1,0), (1,1), … (1,n-1), and so on.
The input ends with a pair of -1’s.

Output
For each test case output in a line the single integer giving the number of blocks of cheese collected.

Sample Input

3 1
1 2 5
10 11 6
12 12 7
-1 -1

Sample Output

37

题意:
从(0,0)开始走,每次最多走k步,下一个位置比现在奶酪多(价值大),获取价值,每次只能水平或垂直走,问最大能得到的价值。

思路:
记忆化搜索上下左右,存最大价值

代码:

#include<stdio.h>
#include<string.h>
#include<algorithm>
using namespace std;
int to[4][2]={0,1,0,-1,1,0,-1,0};
int n,k,a,b,z,map[1100][1100],dp[1100][1100];
int dfs(int x,int y)
{
    if(dp[x][y]>0)
        return dp[x][y];//dp已走过
    else
    {
        int maxx=0;//四周的最大和
        int sum;//当前和
        int tx,ty;
        for(int i=0;i<4;i++)
        {
            for(int j=1;j<=k;j++)
            {
                tx=x+(to[i][0])*j;
                ty=y+(to[i][1])*j;
                if(tx>=0&&ty>=0&&tx<n&&ty<n&&map[tx][ty]>map[x][y])
                {

                    sum=dfs(tx,ty);
                maxx=max(sum,maxx);
            }
        }
    }
    dp[x][y]=maxx+map[x][y];//回溯到m,n时的最大和(从大到小)
    return dp[x][y];
}
}
int main()
{
    while(~scanf("%d%d",&n,&k)&&n!=-1&&k!=-1)
    {
        memset(map,0,sizeof(map));
        memset(dp,0,sizeof(dp));
        for(int i=0;i<n;i++)
        {
            for(int j=0;j<n;j++)
            {
                scanf("%d%",&map[i][j]);
            }
        }
        dfs(0,0);
        printf("%d\n",dfs(0,0));
    }
    return 0;
}

标签:Cheese,cheese,int,FatMouse,---,location,each,dp
来源: https://blog.csdn.net/qq_54088475/article/details/119256126

本站声明: 1. iCode9 技术分享网(下文简称本站)提供的所有内容,仅供技术学习、探讨和分享;
2. 关于本站的所有留言、评论、转载及引用,纯属内容发起人的个人观点,与本站观点和立场无关;
3. 关于本站的所有言论和文字,纯属内容发起人的个人观点,与本站观点和立场无关;
4. 本站文章均是网友提供,不完全保证技术分享内容的完整性、准确性、时效性、风险性和版权归属;如您发现该文章侵犯了您的权益,可联系我们第一时间进行删除;
5. 本站为非盈利性的个人网站,所有内容不会用来进行牟利,也不会利用任何形式的广告来间接获益,纯粹是为了广大技术爱好者提供技术内容和技术思想的分享性交流网站。

专注分享技术,共同学习,共同进步。侵权联系[81616952@qq.com]

Copyright (C)ICode9.com, All Rights Reserved.

ICode9版权所有