ICode9

精准搜索请尝试: 精确搜索
首页 > 其他分享> 文章详细

2021-07-27

2021-07-27 10:04:18  阅读:163  来源: 互联网

标签:0mxi 10 27 07 ll 2021 test x0 include


Recently, Peter saw the equation x0+2x1+4x2+...+2mxm=nx0+2x1+4x2+...+2mxm=n. He wants to find a solution (x0,x1,x2,...,xm)(x0,x1,x2,...,xm) in such a manner that ∑i=0mxi∑i=0mxi is minimum and every xixi (0≤i≤m0≤i≤m) is non-negative.

Input

There are multiple test cases. The first line of input contains an integer TT (1≤T≤105)(1≤T≤105), indicating the number of test cases. For each test case:

The first contains two integers nn and mm (0≤n,m≤109)(0≤n,m≤109).

Output

For each test case, output the minimum value of ∑i=0mxi∑i=0mxi.

Sample Input

10
1 2
3 2
5 2
10 2
10 3
10 4
13 5
20 4
11 11
12 3

Sample Output

1
2
2
3
2
2
3
2
3
2

题意:满足上面等式的情况下,x和最小

贪心思想,递归代码

#include"stdio.h"
#include"math.h"
#include"string.h"
#include"algorithm"
#include"iostream"
using namespace std;
typedef long long ll;
ll dfs(ll x,ll y)
{
	if(x<=0)
		return 0;
	while(y>x) y/=2;
	ll k=x/y;
	if(k*y==x)
		return k;
	else
		return k+dfs(x-k*y,y);
}
int main()
{
	ll y,n,m,w;
	cin>>w;
	while(w--)
	{
		cin>>n>>m;
		if(m>=30)//m>30,y值无法正确计算,会出现runtime error
		m=29;
		y=pow(2,m);
		cout<<dfs(n,y)<<endl;
	}
	return 0;
}

标签:0mxi,10,27,07,ll,2021,test,x0,include
来源: https://blog.csdn.net/qq_52898168/article/details/119134691

本站声明: 1. iCode9 技术分享网(下文简称本站)提供的所有内容,仅供技术学习、探讨和分享;
2. 关于本站的所有留言、评论、转载及引用,纯属内容发起人的个人观点,与本站观点和立场无关;
3. 关于本站的所有言论和文字,纯属内容发起人的个人观点,与本站观点和立场无关;
4. 本站文章均是网友提供,不完全保证技术分享内容的完整性、准确性、时效性、风险性和版权归属;如您发现该文章侵犯了您的权益,可联系我们第一时间进行删除;
5. 本站为非盈利性的个人网站,所有内容不会用来进行牟利,也不会利用任何形式的广告来间接获益,纯粹是为了广大技术爱好者提供技术内容和技术思想的分享性交流网站。

专注分享技术,共同学习,共同进步。侵权联系[81616952@qq.com]

Copyright (C)ICode9.com, All Rights Reserved.

ICode9版权所有