ICode9

精准搜索请尝试: 精确搜索
首页 > 其他分享> 文章详细

(UVA - 11582)Colossal Fibonacci Numbers!(递推+快速幂,无符号长整型)

2021-07-06 15:04:38  阅读:227  来源: 互联网

标签:Colossal llu int 符号长 11582 uLL ans include mod


链接: https://vjudge.net/problem/UVA-11582

The i’th Fibonacci number f(i) is
recursively defined in the following
way:
• f(0) = 0 and f(1) = 1
• f(i + 2) = f(i + 1) + f(i) for
every i ≥ 0
Your task is to compute some
values of this sequence.
Input
Input begins with an integer t ≤
10, 000, the number of test cases.
Each test case consists of three integers
a, b, n where 0 ≤ a, b < 2
64
(a and b will not both be zero) and
1 ≤ n ≤ 1000.
Output
For each test case, output a single line containing the remainder of f(a
b
) upon division by n.
Sample Input
3
1 1 2
2 3 1000
18446744073709551615 18446744073709551615 1000
Sample Output
1
21
250

分析:给出了递推式: f[0]=0,f[1]=1;
f[i+2]=f[i]+f[i+1],i>=0

然后求f[a^b]%n
求出的结果一定是

#include<cstdio>
#include<cstring>
#include<algorithm>
#include<iostream>
using namespace std;
#define mem(a,n) memset(a,n,sizeof(a))
typedef unsigned long long uLL;
const int INF=0x3f3f3f3f;
const uLL N=1e3+5;
uLL F[N*N];
uLL pow_mod(uLL a,uLL b,uLL mod)
{
    uLL ans=1;
    a%=mod;
    while(b)
    {
        if(b&1) ans=ans*a%mod;
        b>>=1;
        a=a*a%mod;
    }
    return ans;
}
int main()
{
    int t;
    scanf("%d",&t);
    while(t--)
    {
        uLL a,b,n;
        scanf("%llu%llu%llu",&a,&b,&n);
//        printf("%llu %llu %llu\n",a,b,n);
        F[0]=0,F[1]=1%n;
        uLL T=1;
        for(int i=2; i<=n*n; i++)
        {
            F[i]=(F[i-1]%n+F[i-2]%n)%n;
            if(F[i]==1&&F[i-1]==0)
            {
                T=i-1;
                break;
            }
        }
        uLL tmp=pow_mod(a%T,b,T);
        printf("%llu\n",F[tmp]);
    }
    return 0;
}

 

标签:Colossal,llu,int,符号长,11582,uLL,ans,include,mod
来源: https://blog.51cto.com/u_13696685/2990202

本站声明: 1. iCode9 技术分享网(下文简称本站)提供的所有内容,仅供技术学习、探讨和分享;
2. 关于本站的所有留言、评论、转载及引用,纯属内容发起人的个人观点,与本站观点和立场无关;
3. 关于本站的所有言论和文字,纯属内容发起人的个人观点,与本站观点和立场无关;
4. 本站文章均是网友提供,不完全保证技术分享内容的完整性、准确性、时效性、风险性和版权归属;如您发现该文章侵犯了您的权益,可联系我们第一时间进行删除;
5. 本站为非盈利性的个人网站,所有内容不会用来进行牟利,也不会利用任何形式的广告来间接获益,纯粹是为了广大技术爱好者提供技术内容和技术思想的分享性交流网站。

专注分享技术,共同学习,共同进步。侵权联系[81616952@qq.com]

Copyright (C)ICode9.com, All Rights Reserved.

ICode9版权所有