ICode9

精准搜索请尝试: 精确搜索
首页 > 其他分享> 文章详细

7-1 字符串替换 (10 分)

2021-07-03 11:03:26  阅读:522  来源: 互联网

标签:10 Xi end Institute University 字符串 found 替换


将文本文件中指定的字符串替换成新字符串。 由于目前的OJ系统暂时不能支持用户读入文件,我们编写程序从键盘输入文件中的内容,当输入的一行为end时,表示结束。end后面有两个字符串,要求用第二个字符串替换文本中所有的第一个字符串。

输入格式:

Xi’an Institute of Posts and Telecommunications is co-designed and implemented by the People’s Government of Shaanxi Province and the Ministry of Industry and Information Technology. The Institute is located in Xi’an, a historic city in Northwest China, famous for its magnificent ancient culture.


end (表示结束)

Institute (第一个字符串,要求用第二个字符串替换)

University (第二个字符串)

输出格式:

Xi’an University of Posts and Telecommunications is co-designed and implemented by the People’s Government of Shaanxi Province and the Ministry of Industry and Information Technology.The University is located in Xi’an, a historic city in Northwest China, famous for its magnificent ancient culture.

输入样例:

Xi’an Institute of Posts and Telecommunications is co-designed and implemented by the People’s Government of Shaanxi Province and the Ministry of Industry and Information Technology.
The Institute is located in Xi’an, a historic city in Northwest China, famous for its magnificent ancient culture.
end
Institute
University

输出样例:

Xi’an University of Posts and Telecommunications is co-designed and implemented by the People’s Government of Shaanxi Province and the Ministry of Industry and Information Technology.The University is located in Xi’an, a historic city in Northwest China, famous for its magnificent ancient culture.

作者
张德慧
单位
西安邮电大学
代码长度限制
16 KB
时间限制
400 ms
内存限制
64 MB
C++ (g++)
代码

#include<iostream>
#include<string>
using namespace std;

int main()
{
	string a, b, c, d;
	getline(cin, a);
	while (1)
	{
		getline(cin, d);
		int i = d.compare("end");
		if (i == 0)
			break;
		a += "\n";
		a += d;
	}
	a += "\n";
	cin >> b;
	cin >> c;
	int found = a.find(b);
	if (found != -1)
	{
		a.replace(found, b.length(), c);
		found = a.find(b, found + 1);
	}
	cout << a;

}

标签:10,Xi,end,Institute,University,字符串,found,替换
来源: https://blog.csdn.net/weixin_45886685/article/details/118437040

本站声明: 1. iCode9 技术分享网(下文简称本站)提供的所有内容,仅供技术学习、探讨和分享;
2. 关于本站的所有留言、评论、转载及引用,纯属内容发起人的个人观点,与本站观点和立场无关;
3. 关于本站的所有言论和文字,纯属内容发起人的个人观点,与本站观点和立场无关;
4. 本站文章均是网友提供,不完全保证技术分享内容的完整性、准确性、时效性、风险性和版权归属;如您发现该文章侵犯了您的权益,可联系我们第一时间进行删除;
5. 本站为非盈利性的个人网站,所有内容不会用来进行牟利,也不会利用任何形式的广告来间接获益,纯粹是为了广大技术爱好者提供技术内容和技术思想的分享性交流网站。

专注分享技术,共同学习,共同进步。侵权联系[81616952@qq.com]

Copyright (C)ICode9.com, All Rights Reserved.

ICode9版权所有