ICode9

精准搜索请尝试: 精确搜索
首页 > 编程语言> 文章详细

【JAVA】1002 A+B for Polynomials (25分) PAT甲级 PAT (Advanced Level) Practice

2020-04-29 14:04:15  阅读:291  来源: 互联网

标签:25 PAT Level int index System sc 1001 out


1002 A+B for Polynomials (25分)

This time, you are supposed to find A+B where A and B are two polynomials.

Input Specification:
Each input file contains one test case. Each case occupies 2 lines, and each line contains the information of a polynomial:
K N1N_1N1​ aN1a_N1aN​1 N2N_2N2​ aN2a_N2aN​2… NKN_KNK​ aNKa_NKaN​K
每个输入文件包含一个测试用例。 每个案例占用2行,并且每行包含一个多项式的信息:
K N1N_1N1​ aN1a_N1aN​1 N2N_2N2​ aN2a_N2aN​2… NKN_KNK​ aNKa_NKaN​K

where K is the number of nonzero terms in the polynomial, NiN_iNi​andaNia_NiaN​i(i=1,2,⋯,K) are the exponents and coefficients, respectively. It is given that 1≤K≤10,0≤NKN_KNK​​<⋯<N2N_2N2​<N1N_1N1​≤1000.
其中K是多项式中非零项的数量,NiN_iNi​andaNia_NiaN​i(i=1,2,⋯,K) 分别是指数和系数。 假设1≤K≤10,0≤NKN_KNK​​<⋯<N2N_2N2​<N1N_1N1​≤1000.

Output Specification:
For each test case you should output the sum of A and B in one line, with the same format as the input. Notice that there must be NO extra space at the end of each line. Please be accurate to 1 decimal place.
对于每个测试用例,应在一行中输出A和B的总和,格式与输入相同。 请注意,每行末尾不得有多余的空间。 请精确到小数点后一位。

Sample Input:
2 1 2.4 0 3.2
2 2 1.5 1 0.5

Sample Output:
3 2 1.5 1 2.9 0 3.2

要点

  1. 最难理解的是题目
    在这里插入图片描述

  2. 请注意,每行末尾不得有多余的空间。

  3. 请精确到小数点后一位。

    System.out.printf("%.1f", C[i]);
    

代码

import java.util.Arrays;
import java.util.Scanner;

public class PolynomialAddition1 {
    public static void main(String[] args) {
        Scanner sc = new Scanner(System.in);
        Double[] A = new Double[1001];
        for (int i = 0; i < 1001; i++) { //防止 C[i] = A[i] + B[i];发生空指针异常
            A[i] = 0.0;
        }
        Double[] B = new Double[1001];
        for (int i = 0; i < 1001; i++) {//防止 C[i] = A[i] + B[i];发生空指针异常
            B[i] = 0.0;
        }

        int K = sc.nextInt();
        int index;
        while (K != 0) {
            index = sc.nextInt(); //指数
            A[index] = sc.nextDouble(); //系数
            K--;
        }
//        System.out.println(Arrays.toString(A));

        K = sc.nextInt();
        while (K != 0) {
            index = sc.nextInt(); //指数
            B[index] = sc.nextDouble(); //系数
            K--;
        }
        sc.close();
//        System.out.println(Arrays.toString(B));

        double[] C = new double[1001];
        int count = 0;
        for (int i = 0; i < 1001; i++) {
            if (A[i] != 0 || B[i] != 0) {
                count++;
                C[i] = A[i] + B[i];
            }
        }
//        System.out.println(Arrays.toString(C));
        System.out.print(count);
        for (int i = 1000; i >= 0; i--) {
            if (C[i] != 0) {
                System.out.print(" " + i + " ");
                System.out.printf("%.1f", C[i]);
            }
        }
    }
}

标签:25,PAT,Level,int,index,System,sc,1001,out
来源: https://blog.csdn.net/weixin_43124279/article/details/105823853

本站声明: 1. iCode9 技术分享网(下文简称本站)提供的所有内容,仅供技术学习、探讨和分享;
2. 关于本站的所有留言、评论、转载及引用,纯属内容发起人的个人观点,与本站观点和立场无关;
3. 关于本站的所有言论和文字,纯属内容发起人的个人观点,与本站观点和立场无关;
4. 本站文章均是网友提供,不完全保证技术分享内容的完整性、准确性、时效性、风险性和版权归属;如您发现该文章侵犯了您的权益,可联系我们第一时间进行删除;
5. 本站为非盈利性的个人网站,所有内容不会用来进行牟利,也不会利用任何形式的广告来间接获益,纯粹是为了广大技术爱好者提供技术内容和技术思想的分享性交流网站。

专注分享技术,共同学习,共同进步。侵权联系[81616952@qq.com]

Copyright (C)ICode9.com, All Rights Reserved.

ICode9版权所有