ICode9

精准搜索请尝试: 精确搜索
首页 > 编程语言> 文章详细

PAT Advanced 1070 Mooncake (25) [贪⼼算法]

2020-01-31 15:05:47  阅读:271  来源: 互联网

标签:billion 25 PAT int thousand 1070 moon tons total


题目

Mooncake is a Chinese bakery product traditionally eaten during the Mid-Autumn Festival. Many types of fillings and crusts can be found in traditional mooncakes according to the regions culture. Now given the inventory amounts and the prices of all kinds of the mooncakes, together with the maximum total demand of the market, you are supposed to tell the maximum profit that can be made.
Note: partial inventory storage can be taken. The sample shows the following situation: given three kinds of mooncakes with inventory amounts being 180, 150, and 100 thousand tons, and the prices being 7.5, 7.2, and 4.5 billion yuans. If the market demand can be at most 200 thousand tons, the best we can do is to sell 150 thousand tons of the second kind of mooncake, and 50 thousand tons of the third kind. Hence the total profit is 7.2 + 4.5/2 = 9.45 (billion yuans).
Input Specification:
Each input file contains one test case. For each case, the first line contains 2 positive integers N (<=1000), the number of diferent kinds of mooncakes, and D (<=500 thousand tons), the maximum total demand of the market. Then the second line gives the positive inventory amounts (in thousand tons), and the third line gives the positive prices (in billion yuans) of N kinds of mooncakes. All the numbers in a line are separated by a space.
Output Specification:
For each test case, print the maximum profit (in billion yuans) in one line, accurate up to 2 decimal places.
Sample Input:
3 200
180 150 100
7.5 7.2 4.5
Sample Output:
9.45

题目分析

已知不同种类月饼的库存,总价格,市场需求量,求最大利润

解题思路

  1. 贪心思想:依次获取单位价格最贵的月饼
  2. 结构体moon,存储月饼的库存,总价格,单位价格(输入总价格时预处理,减少一次遍历)
  3. 按照单位价格降序排序,依次获取,直到达到市场需求量

Code

Code 01

#include <iostream>
#include <vector>
#include <algorithm>
using namespace std;
struct moon {
    double w; // total weight (in thousand tons)
    double p; // total price (in billion yuan)
    double pp; // price per thousand ton
};
bool cmp(moon &m1,moon &m2) {
    return m1.pp>m2.pp;
}
int main(int argc, char * argv[]) {
    // 1 接收数据 
    int N,D;
    scanf("%d %d",&N,&D);
    vector<moon> vms(N); //存放月饼数据 
    for(int i=0; i<N; i++) scanf("%lf", &vms[i].w);
    for(int i=0; i<N; i++) {
        scanf("%lf", &vms[i].p);
        vms[i].pp = vms[i].p/vms[i].w; //计算每重量单位的价格 
    }
    // 2 按照单位价格高-低排序 
    sort(vms.begin(),vms.end(),cmp);
    // 3 求最大利润 
    double tp = 0.0;
    for(int i=0; i<N&&D>0; i++) {
        if(vms[i].w<D) {//如果当前月饼种类的重量小于需求剩余数,全部销售 
            D=D-vms[i].w;
            tp+=vms[i].p;
        } else { //如果当前月饼种类的重量大于需求剩余数,按照单位价计算剩余需求重量 
            tp+=D*vms[i].pp;
            D=0;
        }
    }
    printf("%.2f", tp);
}


标签:billion,25,PAT,int,thousand,1070,moon,tons,total
来源: https://www.cnblogs.com/houzm/p/12245407.html

本站声明: 1. iCode9 技术分享网(下文简称本站)提供的所有内容,仅供技术学习、探讨和分享;
2. 关于本站的所有留言、评论、转载及引用,纯属内容发起人的个人观点,与本站观点和立场无关;
3. 关于本站的所有言论和文字,纯属内容发起人的个人观点,与本站观点和立场无关;
4. 本站文章均是网友提供,不完全保证技术分享内容的完整性、准确性、时效性、风险性和版权归属;如您发现该文章侵犯了您的权益,可联系我们第一时间进行删除;
5. 本站为非盈利性的个人网站,所有内容不会用来进行牟利,也不会利用任何形式的广告来间接获益,纯粹是为了广大技术爱好者提供技术内容和技术思想的分享性交流网站。

专注分享技术,共同学习,共同进步。侵权联系[81616952@qq.com]

Copyright (C)ICode9.com, All Rights Reserved.

ICode9版权所有