ICode9

精准搜索请尝试: 精确搜索
首页 > 其他分享> 文章详细

ACM题目 1083: Hello, world!

2020-09-07 15:01:46  阅读:403  来源: 互联网

标签:1083 EOF int end ACM 108 111 corresponding Hello


题目描述:

This is the first problem for test. Since all we know the ASCII code, your job is simple: Input numbers and output corresponding messages.

输入:

The input will contain a list of positive integers separated by whitespaces(spaces, newlines, TABs). Please process to the end of file (EOF). The integers will be no less than 32.

输出:

Output the corresponding message. Note there is NOT a newline character in the end of output.

样例输入:

72 101 108 108 111 44
32 119 111 114 108 100 33

样例输出:

Hello, world!

思路:

将所有数字存放到一个数组中

然后对数组中每一个数字取整数输出

代码:

#include<stdio.h>
int main()
{
    char c;
    int a[100],i=0;
    while((scanf("%d",&a[i]))!=EOF)
    {
        i++;
    }
    for(int j=0;j<i;j++)
        printf("%c",a[j]);
    return 0;
}

  

 

标签:1083,EOF,int,end,ACM,108,111,corresponding,Hello
来源: https://www.cnblogs.com/redzzy/p/13626907.html

本站声明: 1. iCode9 技术分享网(下文简称本站)提供的所有内容,仅供技术学习、探讨和分享;
2. 关于本站的所有留言、评论、转载及引用,纯属内容发起人的个人观点,与本站观点和立场无关;
3. 关于本站的所有言论和文字,纯属内容发起人的个人观点,与本站观点和立场无关;
4. 本站文章均是网友提供,不完全保证技术分享内容的完整性、准确性、时效性、风险性和版权归属;如您发现该文章侵犯了您的权益,可联系我们第一时间进行删除;
5. 本站为非盈利性的个人网站,所有内容不会用来进行牟利,也不会利用任何形式的广告来间接获益,纯粹是为了广大技术爱好者提供技术内容和技术思想的分享性交流网站。

专注分享技术,共同学习,共同进步。侵权联系[81616952@qq.com]

Copyright (C)ICode9.com, All Rights Reserved.

ICode9版权所有