ICode9

精准搜索请尝试: 精确搜索
首页 > 其他分享> 文章详细

HDU 4738 Caocao's Bridges 桥

2020-02-22 15:45:25  阅读:330  来源: 互联网

标签:Bridges HDU Zhou int Caocao dfn low islands Yu


一、内容

 Caocao was defeated by Zhuge Liang and Zhou Yu in the battle of Chibi. But he wouldn't give up. Caocao's army still was not good at water battles, so he came up with another idea. He built many islands in the Changjiang river, and based on those islands, Caocao's army could easily attack Zhou Yu's troop. Caocao also built bridges connecting islands. If all islands were connected by bridges, Caocao's army could be deployed very conveniently among those islands. Zhou Yu couldn't stand with that, so he wanted to destroy some Caocao's bridges so one or more islands would be seperated from other islands. But Zhou Yu had only one bomb which was left by Zhuge Liang, so he could only destroy one bridge. Zhou Yu must send someone carrying the bomb to destroy the bridge. There might be guards on bridges. The soldier number of the bombing team couldn't be less than the guard number of a bridge, or the mission would fail. Please figure out as least how many soldiers Zhou Yu have to sent to complete the island seperating mission. 

Input

There are no more than 12 test cases.

In each test case:

The first line contains two integers, N and M, meaning that there are N islands and M bridges. All the islands are numbered from 1 to N. ( 2 <= N <= 1000, 0 < M <= N 2 )

Next M lines describes M bridges. Each line contains three integers U,V and W, meaning that there is a bridge connecting island U and island V, and there are W guards on that bridge. ( U ≠ V and 0 <= W <= 10,000 )

The input ends with N = 0 and M = 0.

Output

For each test case, print the minimum soldier number Zhou Yu had to send to complete the mission. If Zhou Yu couldn't succeed any way, print -1 instead.

Sample Input

3 3
1 2 7
2 3 4
3 1 4
3 2
1 2 7
2 3 4
0 0

Sample Output

-1
4

二、思路

  • 求价值最小的桥。若价值为0,那么还是得派一个人。
  • 若图不连通,那么不需要派人。

三、代码

#include <cstdio>
#include <cstring>
#include <algorithm>
using namespace std;
const int N = 1e3 + 5, M = 2 * N * N;
struct E {int v, w, next;} e[M];
int n, m, len, u, v, w, h[N], num, dfn[N], low[N];
bool brid[M];
void add(int u, int v, int w) {e[++len].v = v;  e[len].w = w; e[len].next = h[u]; h[u] = len;}
void tarjan(int u, int in_edge) {
	dfn[u] = low[u] = ++num;
	for (int j = h[u]; j; j = e[j].next) {
		int v = e[j].v;
		if (!dfn[v]) {
			tarjan(v, j);
			low[u] = min(low[u], low[v]);
			if (dfn[u] < low[v]) brid[j] = brid[j ^ 1] = true;
		} else if ((j ^ 1) != in_edge) low[u] = min(low[u], dfn[v]);
	}
}
int main() {
	while (scanf("%d%d", &n, &m), n) {
		memset(h, 0, sizeof(h)); len = num = 1;
		memset(dfn, 0, sizeof(dfn));
		memset(brid, false, sizeof(brid));
		for (int i = 1; i <= m; i++) {
			scanf("%d%d%d", &u, &v, &w);
			add(u, v, w); add(v, u, w);
		}
		int cnt = 0;
		for (int i = 1; i <= n; i++) if (!dfn[i]) tarjan(i, 0), cnt++;
		int ans = 1e9;
		for (int j = 2; j <= len; j += 2) {
			if (!brid[j]) continue;
			ans = min(ans, e[j].w);	
		}
		if (cnt == 1) printf("%d\n", ans == 1e9 ? -1 : (ans == 0 ? 1 : ans));
		else printf("%d\n", 0); //如果本身不连通 那么不需要派人 
	}
	return 0;
}
嘿呀! 发布了448 篇原创文章 · 获赞 457 · 访问量 7万+ 私信 关注

标签:Bridges,HDU,Zhou,int,Caocao,dfn,low,islands,Yu
来源: https://blog.csdn.net/qq_41280600/article/details/104444499

本站声明: 1. iCode9 技术分享网(下文简称本站)提供的所有内容,仅供技术学习、探讨和分享;
2. 关于本站的所有留言、评论、转载及引用,纯属内容发起人的个人观点,与本站观点和立场无关;
3. 关于本站的所有言论和文字,纯属内容发起人的个人观点,与本站观点和立场无关;
4. 本站文章均是网友提供,不完全保证技术分享内容的完整性、准确性、时效性、风险性和版权归属;如您发现该文章侵犯了您的权益,可联系我们第一时间进行删除;
5. 本站为非盈利性的个人网站,所有内容不会用来进行牟利,也不会利用任何形式的广告来间接获益,纯粹是为了广大技术爱好者提供技术内容和技术思想的分享性交流网站。

专注分享技术,共同学习,共同进步。侵权联系[81616952@qq.com]

Copyright (C)ICode9.com, All Rights Reserved.

ICode9版权所有